I can't watch Prime videos on Amazon.com

#1

I been trying to watch videos on amazon.com but I get this message:

When I try to change the Settings under Settings > Content Settings > Protected Content

I see this screenshot. I hit that toggle two times and it doesn’t work.

I tried updating the browser but as of now I am on the latest build.

I tried deleting my cookies and cache with no luck.

I tried turning the shields off with no luck either.

I tried to reset the settings of the browser but I cannot reset it either and it stays doing the circle thing and it never stops

BTW the website works in Firefox.

This is my build.

Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)

Maybe it has something to do with Chromium on Linux because I can’t watch Prime Videos on the Linux version either because it says it’s not compatible (it states it is compatible with Chrome though )

#2

@bandito search for puzzle icon at URL bar > Install and run Widevine. Widevine is disabled by default and you need to enable it first.

EDIT:
Just saw you mentioned about Linux. Widevine support for Linux will be available with 0.62.x release.

1 Like
#3

Thanks for the help. I’ll just patiently wait for the 0.62 version.

closed #4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.