I cannot print using the Brave Browser


#1

Before you post!

1. It is important that you have the right expectations for free technical support for free open source software.

For an average business day you should expect about 24 hours before your first response. For the weekend (any post after 3PM PST Friday to 11AM PST Monday) expect about 48 hours before your first response.

We totally love you, but we also have loved ones, pets, and stuffed animals we like to spend time with when we’re not making free software.

2. Did you check out our Common Issues? https://community.brave.com/c/common-issues

Clicking on that Lion in the upper-right corner and fiddling with settings is going to solve like 99% of your problems.

3. Keep It Tidy

Rather than posting “+1” or “Agreed”, use the Like button. Rather than taking an existing topic in a radically different direction, use Reply as a Linked Topic.

4. On the Internet nobody knows if you are being funny/sarcastic/rude.

Smileys go a long way, but it’s better if you stick to the facts and say ‘please’ and ‘thank you’. Don’t swear in text, it’s a waste of everyone’s energy.

Any kind of harassment/impersonation/spam will not be tolerated. Once acknowledged. your account will be banned.

5. Help us help you. This is how we expect you to write a post:

  • A. Make a meaningful title. “Clicking on the Done button 3 times crashes Brave” is much better than “Brave suddenly crashed”.
  • B. A screenshot or recording of the issue (Licecap is totally free to use http://www.cockos.com/licecap/)
  • C. A listing of:
    • i. Your Operating System and version (Mac 10.11.x, Windows 7/8/10, Linux distribution, iOS 9/10, Android)
    • ii. Your Brave Version. (Desktop users please copy info from about:brave using the clipboard if possible)
  • D. Detailed step-by-step instructions of how you came across the issue.
    Example:
    • i. I downloaded and installed Brave.
    • ii. I created a bookmark and clicked the ‘Done’ button three times.
    • iii. Brave suddenly quit and my bookmark was not created.
  • E. Count to 20 and re-read your post. Could someone take offense at your post? Could you say something a bit more clearly?

6. If you do not follow the guidelines above, expect to have your post edited or deleted.

We’re not trying to be rude, we just don’t want to waste energy when we could be releasing new features and bug fixes.

7. Thanks for slowing down to read this. Use the template in step 5 and you can delete the rest.


#2

I am using a HP computer on Windows 10. I am not able to print to my normal printers in my office. I can open up any other browser and it prints no problem. Has anyone else had this issue? I have tried to turn off the shield but that did not help.


#3

Just after today’s update, Brave stopped being able to print. After sending the print job to any printer, I can see it appearing in spooling buffer for about a millisecond and disappear, then nothing happens - whether print job is send to a local, network or PDF printer. NADA, NULL, ZIP. HELP PLEASE - I need to print from the browser. If this is not fixed - I will have to go back to Chrome… :frowning:


#4

Same thing for me. It has been happening for a week for me.


#5

Hi @jbeck619 and @tooreck

Could you both post your Brave and OS versions?

Thanks,
Lauren


#6

Hi - thanks for the quick reply. Here is the data for:

  1. BRAVE
    |Brave|0.21.24|
    |—|---|
    |V8|6.5.254.36|
    |rev|19c78a1|
    |Muon|4.9.3|
    |OS Release|6.1.7601|
    |Update Channel|Release|
    |OS Architecture|x64|
    |OS Platform|Microsoft Windows|
    |Node.js|7.9.0|
    |Brave Sync|v1.4.2|
    |libchromiumcontent|65.0.3325.162|
  2. WINDOWS
    Windows 7 Enterprise 64-bit SP1

#7

Thanks for sending @tooreck - I have logged an issue for this:

Best,
Lauren


#8

Thanks! What happens next?


#9

I have the same exact problem here is the info Lauren

brave version 0.21.24

windows 10 home version 1709


#10

I have sent the issue to development, so they will review. Your best bet is to keep an eye on the issue I linked above, as the most up to date information will be posted there.

Thanks for the additional info @revdoomdr!!

Best,
Lauren


#11

Windows 7 professional
HP Compaq Elite 8300 SFF
Brave Version 0.21.24


#12

I have the same issue as well. I tried printing from Brave on two different computers (an HP laptop and HP desktop) to two different printers (Epson & HP) and nothing happened. I also tried printing a PDF of the page I was trying to print with the same result–no PDF appeared in the folder. I am on my laptop now, so here is the information of that:

Brave: 0.21.24
V8: 6.5.254.36
rev: 19c78a1624118e344852c4c0f44c0d45be841b5f
Muon: 4.9.3
OS Release: 10.0.16299
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 65.0.3325.162


#13

I should add that I checked the drivers and they were the latest versions–and I was able to print without any problem from the HP app (printing an existing document) and when I used the MS Edge browser.


#14

I use EBAY postage and after the last update, Brave will no longer print my postage label. The printer menu comes up and it looks like it’s pointing to my printer. I choose to print the label. The menu disappears, but nothing is sent to the printer. – 0 documents. I change to Firefox and can print with no problems on the same laptop to the same printer.

I’m on Windows 10 trying to print to an Epson XP-800 which worked with Brave until the last update.

Brave:

Brave 0.21.24
Brave Sync v1.4.2
libchromiumcontent 65.0.3325.162
Muon 4.9.3
Node.js 7.9.0
OS Architecture x64
OS Platform Microsoft Windows
OS Release 10.0.16299
rev 19c78a1
Update Channel Release
V8 6.5.254.36

#15

Same thing exactly; flash that is uncatchable going to the print server when you hit the print button, but no document sent to printer and no record of it existing. I’m on a Windows 10 machine

Brave 0.21.24
V8 6.5.254.36
rev 19c78a1
Muon 4.9.3
OS Release 10.0.16299
Update Channel Release
OS Architecture x64
OS Platform Microsoft Windows
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 65.0.3325.162

,


#16

Yikes.Same issue with me in ebay, I can usually get around it. Where do you find which version of brave you are using?


#17

Is it possible to download a prior version before the issues started?


#18

fofa

    March 23

Yikes.Same issue with me in ebay, I can usually get around it. Where do you find which version of brave you are using?


#19

I uninstalled the 0.21.24 version and uploaded a new version, but the problem remains.


#20

I found a work around. Since ebay and inside PayPal doesn’t work printing labels (0 documents in queue and absolute silence from the black beast box) I get the label paid for and up on the screen, then highlight and download and save in documents, then hit open with either of two pdf viewers I have and prints fine. Yeah it’s a work around that takes some time but beats going to my sister’s house to print things off :smiley: