I am blocked from a website, why?

When trying to visit “leroymerlin.fr” I get a message from that website stating that I am blocked because

  • I am surfing and clicking with superhuman speed or
  • there is something on my computer blocking javascript or
  • there is some kind of bot installed on the network as my laptop.

I used the default settings in Shields and I have disabled it for this particular website but it doesn’t make any difference; it still doesn’t work.
The site works as expected when using Chrome

I am using version 1.42.88 on Linux.

Any ideas?

I went to the link and everything runs with no issues. That makes it a bit more challenging to know what to tell you. I’m wanting to assume it’s likely one of your extensions causing issues. I’d maybe try opening it in Private window and see if it has the same issue.

It happens also in a private window.
Even when I have all extensions disabled.
Can you enter a product category (access to the database)?
I can’t…


Yep. It’s blocked. Tried accessing the above mentioned website and it shows blocked. Tried in private window as well as private window with tor… still blocked. Tried in microsoft edge as well and same result. Definitely something to do with region and location restriction. Try switching locations using a vpn and accessing it on a browser other than brave for the sake of not getting your wallet flagged :stuck_out_tongue:

1 Like

I don’t agree with you about the region restriction.
When I use Google’s Chrome I have absolutely no problems accessing this website…
Besides, it’s a french website and, guess what, I’m in France.
This drives me crazy, almost…


1 Like

I can confirm. Opening a product shows the Blocked message. It works with other browsers though.

1 Like

Blocks me, based on my NZ IP. Server side check. Not a Brave issue btw

I don’t agree. I can use this website on Chrome and Firefox without any problems. So it cannot be a geo-block. Besides, it’s a french website and I am in France, using a french internet-access-provider (Orange). So it could be you are blocked because of your IP but I am not. I can see in your screenshot you are only given one reason. I got three; besides the same as yours it could be javascript is blocked or, and that’s a nice one, I surf/click at superhuman speed…

It is a Brave issue because it works with other browsers. I have tested it myself.

From Chrome, Firefox.

Switching my VPN location to France allows the page to show on all browsers.

Check your DNS settings for brave brave://settings/security

Is it ‘Use secure DNS’, if so then is it ‘Current provider’ or custom provider
If it is custom one, which was is it?

And see the same for chrome or firefox on your device.

Also, provide your screenshot (your 3 reasons)

It makes no difference if I disable Secure DNS or not. The problem appears only in Brave. I use default settings in all three mentioned browsers but I have no problems in Chrome or Firefox. So it is Brave that creates the problem…I think…

I confirm again.

I am not in France. I can see the products with Edge, Chrome and FF. I cannot with Brave.

Changing the DNS security settings does not make any difference. The Chrome DNS Security settings are the same as in Brave.

Thanks Rodrige for checking!

I downloaded a Chrome extension to switch the user-agent and guess what?
When I change it from Chrome (default) to, let’s say, Opera I have no problems navigating the site. So it is definitely a problem that has to do with how Brave behaves.
Now I just need a solution and no workaround as mentioned above…

Well, I don’t know what to say. I went to it and went to navigate, I ended up with the same thing about being a robot or whatever. I tested it in Chrome and was able to get to it with no issues.

Then I came back to Brave and turned off Shields. When I did that, I had the cookies message come up, where I said to continue sans cookies or w/e. It was able to allow me to navigate through everything.

So then I turned Shields back on and went to the site. Everything loads and works perfectly.

That did the trick! Don’t understand why but that doesn’t matter at the moment. It works.
Thanks for all the help!

Edit: when trying other websites I came to the conclusion not all changes on cookies were saved in Brave. After deleting the cookie and letting the website create a new cookie everything went fine.
When installing Brave I imported data from Google Chrome. It seems to me that there is an incompatibility between some cookies from Chrome and Brave/Shields.
So I have come to the conclusion that it is best to delete all cookies and start from scratch to avoid such problems in the future…I hope.

1 Like

And again Brave fails to let me load the website while other browsers work fine.
I’m gonna swith back to Chrome and uninstall Brave…

I just clicked that link here with brave (I am in germany) and the page loaded without any problem.

Have you tried clicking a category on the left and choosing an article? That’s where Brave goes wrong and others don’t (at least in my experience).