Hyperlinks opens in the wrong profile

I have two profiles on Brave, one personal and one for work.

When having the personal profile window ‘active’ but laying the background while using macOS native mail app, and I then click a hyperlinks in a mail, it then opens a new Brave window with my work profile instead.

So what I’m saying is, that I’d like Brave to only open hyperlinks in the active profile - or that I maybe had the option of setting a ‘hyperlink default profile’.

Version 1.41.100 Chromium: 103.0.5060.134 (Official Build) (arm64)

Do you have the ability to modify the commandline used when Mail launches your browser?

If so, I wonder what would happen if you specify your ‘Default’ profile (assuming this is your personal one) using --profile-directory.

https://peter.sh/experiments/chromium-command-line-switches/#profile-directory

Thanks for your reply Jim.

I am not familiar with modifying commandlines, but I’d like to give it a try. Do you have a guide that I can follow or can you give directions?
Is this done in the Mac’s terminal, the Mail app or Brave?

Edit: Another topic about this issue - How-to force brave to always open in a specified profile

OK, thanks for that other topic. Seems we may be on the right track here.

Not sure exactly how to do it on macOS, can do some checking later. But it wouldn’t be in Brave; my first guess would be somewhere in your mac’s Settings, or if not there, then in the Mail app’s settings.

Unless it will just always use your default browser, in which case, we might need to find a way to edit the setting for that.

So it looks like this might actually be a Chromium issue:
https://bugs.chromium.org/p/chromium/issues/detail?id=813612&q=is%3Astarred&can=2

A team member of our is going to see if its feasible to add a setting and/or flag that would make it so a “profile picker” option appears before the link actually opens in the browser. Will be sure to update here with the answer.

3 Likes