Hyperlink issue

When I click on a hyperlink in email or website it is rerouted to an expired version of Brave. this is a new issue, any suggestions

I assumed you talked about Brave (muon) – 0.25.x – which is now no longer supported.

If you done import your browser data from prev. Brave

And recover your Brave Rewards wallet too (if you have any)

You can uninstall the old Brave and set the new version Brave as default.

Got it thanks


I have the same problem as “lehnne”, but none of the solutions proposed by “eljuno” worked for me.

Here are the symptoms:
Windows 8.1, updated Brave 0.27.3 to Brave 1.01
When I click on a hyperlink (when Brave is the default browser), Brave 0.27.3 gets started & it tells me it is out of date & to start using the latest version.

Here is what I did to resolve this problem without any success:
1- Uninstalled Brave from my PC, (only one could be found), rebooted PC, then reinstalled Brave 1.0.1.
Result= problem unchanged.

2- Uninstalled Brave 1.0.1, erased all Brave directories, erased all Brave registry entries, rebooted PC, reinstalled Brave 1.0.1.
Result= problem unchanged.

Thank you in advance for your help.

I believe all you have to do is go to System Settings --> Default Apps and ensure that Brave (1.1.20) is set to be the default app for html links.

Hello Mattches,
Thank you for your suggestion.
Unfortunately, on Brave 1.1.20, I can not find the " System Settings --> Default Apps" that you mentioned.
Nevertheless, I had set Brave 1.1.20 as my default browser, which made it strange that it would invoke an older version of that browser when I clicked on an hthml link.

This is because when the browser is set to Default, it doesn’t automatically change the reg entires for all system defaults. So the previous version may have been set as your default app for opening HTML links/files. So when you went to open them, it attempted to launch that version instead of the new one.

You can get to this window by going typing Settings --> Apps --> Choose default apps by file type. Scroll down to the HTML File (.html) option, then change the app to Brave:

Hello Mattches
Thank you for this quick reply!
Unfortunately my Brave interface is nothing like yours, I still can not follow your indications.
Here is a screenshot of my interface:

Also, just to be sure, I restored all settings to their original defaults, but I still don’t get the same menus as yours!

@oli_123456 not a Brave Settings. But your Windows Settings.

1 Like

@eljuno is correct – the images I shared are that of my Windows 10 System settings, not Brave settings. Apologies if that was unclear!

Hello eljuno & Mattches
Thank you both for this precision.
Unfortunately applying it to both .html and .htm does not solve my problem as the old Brave version still get invoked, thus I have 2 versions of Brave on my PC.
By the way I don’t know were this older version is on my HDD as when I deleted Brave the system did not ask which version to delete & I deleted all directories & all registry keys.

Hello eljuno & Mattches --PROBLEM SOLVED–
Thank you again for your help.
I am ashamed to say that you were correct in the 1st place, namely that the previous version of Brave (v0.27.3) was still installed on my PC despite all my efforts to erase all Brave versions!

*** For the record ***
I used iobit uninstaller, which usually does a more thorough job than the Windows uninstaller, EXCEPT that iobit uninstaller did not see the previous version (i still don’t know where it was on my HDD!).
Thus one has to use the Windows uninstaller to get rid of the older version of Brave.

1 Like