Https problems with registering my website

I’m trying to verify my website through the Brave payments. The process is stuck at the ‘https’ verification point. I get a message “Uh oh! Your domain is NOT using HTTPS. You will need to fix that before continuing.”

My domain is using https so I think the problem is on the side of Brave.

Can you please check?

Thank you!

Thanks for reaching out @petrajordan.

cc @Asad to help you on this. :slightly_smiling_face:

Thank you, @eljuno! Do I need to contact @Asad or will he be notified by being tagged in this message?

Hi Petra,

I wrote back to you awhile ago – check your email spam folder(s)! Either way, will get back to you here, too. :slight_smile:

I would suggest deleting your channel and attempting the verification process from scratch again. I can see that HTTPS is indeed active on your site, so it’s possible this is an issue on our end. Let me know if that works for you.

Hi Asad,

thank you!

I looked for the option to delete the channel and restart the whole process but I simply don’t see ‘Remove channel’ option next to Only next to the already activated channels.

Can you please help?

Thank you


Oh never mind - I verified it manually by creating a TXT record in my DNS settings. It worked!

But you may want to make it easier for users by adding the option to delete the channel that is in the process of verification - which is missing as you can see by the screenshot above.

Thank anyway, I’m all set now!

Hi Petra,

Glad you got it working – DNS verification was going to be my next suggestion.

Appreciate your feedback. :slight_smile: We’re always trying to find ways to make verification easier!

This topic was automatically closed after 30 days. New replies are no longer allowed.