HTTPS Certificate Error Exceptions


#1

Prior to my recent upgrade to version 0.13.0, I would receive a HTTPS Certificate Error whenever I went to any of my companies intranet sites. At this point I would tell Brave to ignore it and let me in. This was annoying as it never remembered what I wanted for this site & thus I had to do it everyday, but at least it worked.

Now there is no way to ignore the certificate error (only see a “Back to Safety” button) & thus I can no longer log into any of my companies intranet sites, some of which I use extensively every day. Is there any chance of adding in a setting to allow this to work again. Even if it is only used for intranet (i.e. LAN, instead of WAN) connections.


#2

I have something similar. I’m running Brave on a Mac. I was hoping that there was a way to remember the certificate so the certificate error doesn’t pop up.


#3

At current, we do not store exceptions and it is very unlikely we ever will due to security concerns.

You should be able to install a root cert from your organization though.


#4

For any cert error page, you should see this:

Click on ‘Advanced settings’

You should then be able to choose ‘Ignore certificate error’ and proceed. As mentioned above, it is better for your organization to provide a root cert though.


#5

All I got, on multiple attempts was the “Back to safety” button but the other “Advanced Settings” had disappeared after I upgraded. So I went back to get a screenshot to post and have discovered that the button is back again.

Very strange though as to why it suddenly works but I’m not going to complain now that I can get back onto the intranet sites. :smile:

I’ll open a defect should it re-occur at some point. Thanks for the help.


#6

I am also ONLY getting a back to safety button… I have my own cert on my own website


#7


#8

Hi,

I know this is an older topic, but it was the only google result coming up when I ran into this same issue. How can I add a root certificate? I’ve looked in preferences under ‘Security’ and ‘Advanced’ but I can’t find it.