How to stop YouTube from autoplaying next video immediately

On Firefox or other browsers, when a YouTube video is done playing, it waits 7 second before autoplaying the next video, during which time you can cancel the autoplay. With Brave, the next video plays immediately without any delay so you have no opportunity to cancel if you don’t want to watch the next recommended video. What’s more, if you press the back button, it will take you back to the previous website you were on before YouTube; it’s like you never watched the previous video at all. I even turned off autoplay within the YouTube player, but it still continues to autoplay. This happens both with shield up and shields down. How do I fix this?

I’m sure you can do this in youtube natively

1 Like

I found that the source of my problem is the AutoTube extension which behaves differently to a similar extension that I used on Firefox. For anyone checking this thread in the future, you can turn off autoplay in the extension.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.