How to Stop YOUTUBE autoplaying on tab switch

Quick scenario: Open Youtube and right click a video → open in new tab. Do that a few times and have a few youtube videos of any type lined up. Switch to one of the tabs and the video automatically starts. Youtube autoplay at the bottom of the videos is set to off.
This is very annoying. I want to switch to one of the tabs as described above without video starting until I press play.

Any help gratefully accepted.

Apparently, after a lot of research this is a know issue. One that has been forced upon us. According to one comment regarding stopping autoplay.
" You cant, google removed the option to do so a while ago and makes it very hard to find that out. Eventually you figured out google did this on purpose to force you to have the videos play automatically for profit reasons"

This is a real annoyance to me and WILL be a deal breaker as far as what browser I use if it is not remedied.

REPLY

@Legion99,
This is a known issue that the team is a looking into presently:

I don’t know if this will work for linux, but when i tested this out a bit more thoroughly on windows, i found that having my extensions enabled , i use ublock origin and no script, youtube videos would bypass the auto play block.

But when i disabled my extensions, brave would always block videos from auto playing, and work normally

So why are extensions having an overriding effect …

I have just tried a vanilla install of Chromium in Linux and in every case the videos auto started when the tab was opened. There are zero extensions, I was not logged in and the auto switch was off. I know Chromium is not Brave but it does seem the behaviour is built into Chromium → Chrome → Brave but, if it is as you say, something added to Brave prevents the issue but that is being countered by an extension, Not countering what you said but another piece of the puzzle. This is something that needs fixing ASAP IMO either by extension or design.

you might be on to something Legion99 that this is baked into Chromium. I have same problem on Windows (Video does not stay paused on streaming video) with Brave but not with FireFox or PaleMoon.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.