How to stop automatic country redirects

I clicked yes on a pop-up that asked if i wanted to view the local version of that website. Unfortunately now i am unable to go back and view the original website. Is there anyway i can stop the automatic redirect to my countries version of a website? I am using iPhone.

Also I searched a lot for a solution with no one having the same problem.

Turning on ‘blocks-scripts’ breaks the website.

Is there a setting on Brave Browser that can stop country redirects?

Also I tried to put this in the ‘help-me’ section.

It’s really up to the website how they implement geotargeting. You could try clearing your cookies (assuming the website stored your choice in a cookie) and open the original website again. History > Clear browsing data > Cookies and other site data. Mind that this will log you out everywhere.

1 Like