How to set System Proxy in Brave Browser

How to set proxy in brave browser.

I followed the below steps but somehow the browser is not picking up proxy pac details

Which desktop environment are you using in Linux? KDE or Gnome? The proxy is set there, which is a system-wide proxy

I’m using MXLinux

$ uname -a 
Linux 5.8.0-3-amd64 #1 SMP Debian 5.8.14-1~mx19+2 (2020-10-25) x86_64 GNU/Linux

$ echo $DESKTOP_SESSION
xfce

Also, I have set proxy in ~/.bashrc
image

Have you tried using a 3rd-party ip proxy, just to test?

No I haven’t tested with 3rd party proxy, The proxy works in linux shell cli but its not picking up in brave browser.

Also in google chrome passing proxy in argument works fine but the same doesn’t work in brave

google-chrome-stable --proxy-server="http://127.0.0.1:8080;https://127.0.0.1:8080"

What error messages show? I can get someone to take look.

I think brave is not passing thru proxy server


To replicate this issue you could run this mitmproxy and test it

docker run --rm -it -v ~/.mitmproxy:/home/<replace-with-your-username>/.mitmproxy -p 8080:8080 mitmproxy/mitmproxy

example:
docker run --rm -it -v ~/.mitmproxy:/home/john/.mitmproxy -p 8080:8080 mitmproxy/mitmproxy

the proxy would be running at 127.0.0.1:8080

The below command line works but I want the same to be applied in brave

http_proxy=http://localhost:8080/ curl http://cnn.com/

Try disabling (ads and trackers) shields globally in brave://settings/shields, then close/restart the browser.

I have not tested http proxies, but socks proxies do work in Brave:

brave-browser-nightly --proxy-server="socks5://localhost:9000"

where I start mitmproxy like this:

mitmproxy --mode socks5 --listen-port 9000

I tried but I’m unable to capture the traffic using the proxy

mitmweb --mode socks5 --listen-port 9000 
Web server listening at http://127.0.0.1:8081/
Proxy server listening at http://*:9000

brave-browser-stable --proxy-server="socks5://localhost:9000"

Did you also enable the MITM certificate authority in Brave?

https://docs.mitmproxy.org/stable/concepts-certificates/#quick-setup

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.