How to set default e-mail link destination to non-gmail site?


#1

Whenever I click a mailto link in Brave (OSX v0.12.15) it takes me to gmail. Is there a way to make it use a different site?


Mac: Brave keeps usurping mailto: links
#2

My Windows 10 Brave was using Outlook for mailto: links, including from a bookmarklet, but then started using gmail and I cannot switch it back. Default mail handler in Windows is set to Outlook.


#3

@neurodynamic Could you check if the protocol handler is set to gmail under Security in the preferences page.


#4

I can’t find the protocol handler setting under Security (or other Preferences tabs). There is a place where protocol permissions are allowed for gmail in the “Saved Site Permissions” section, but nothing other than that as far as I can tell, and deleting that “Allow” setting doesn’t seem to have an effect on behavior.


#5

Like neurodynamic, I don’t see a setting for protocol handler on the Security tab (or any other tab). The bottom of my Security tab looks like this:


#6

We haven’t exposed a way to unregister navigator registered protocols yet, but you can use this hack to get by in the meantime.

If you’re using .12.15:

Press Shift+F8 to open the browser level dev tools, then click on the console tab.
Then run this:

require('electron').remote.protocol.unregisterNavigatorHandler('mailto', 'https://mail.google.com/mail/?extsrc=mailto&url=%s')


#7

Great! Thanks so much… now I can send links via Outlook again (after allowing an external application each time).

Thank you!

P.S. Just for the sake of completeness, is there a hack to re-register gMail as the mailto: handler?


#8

Yep. You should be able to clear the permissions section in preferences for deny site to register protocols if gmail isn’t showing you the notification bar. You can do that and the notification bar to register will come up again the next time you visit gmail.


#9

Hi Brian,
Thanks for the info. I don’t see anywhere to clear permissions for deny site… there are just a couple of permissions to Show notifications.
I did try rerunning: require(‘electron’).remote.protocol.unregisterNavigatorHandler(‘mailto’, ‘https://mail.google.com/mail/?extsrc=mailto&url=%s’)

and the next time I opened gmail, the notification bar to register came up, so all is well.

Thanks for the help!!

jim


#10

Shift-F8 does not work on my keyboard in version 0.13.5. I need to get Outlook working as my email app and not Gmail. Is there a way I can get this changed?


#11

Hello Brian,
I tried this myself but an exception was thrown: Uncaught ReferenceError: require is not defined at …
Is there another way around this issue and why has Brave been hijacked by Gmail / Google in regard to email links?

Thank you
-John


#12

I’m having the same problem as @JASHome. This fix does not appear to work and the mailto function in Brave insists on launching GMail rather than Outlook.


#13

I’m having this same problem. Just created a gmail account and now Brave defaults to that. I don’t want to use the gmail account most of the time! How do I change this?

I tried the hack but receive this message:
Uncaught ReferenceError: require is not defined
at :1:1
(anonymous) @ VM85:1


#14

My problem is the opposite. I need to change the email defaults to is gmail and not outlook. It is now stuck on outlook.