How to save Usernames and passwords using private browsing mode

Hi I was wondering How I would go about getting the brave browser to save My usernames and passwords for any site that I want. But for now I’m focused on Facebook and Youtube. I’m using brave in private browsing mode. I have gone to settings at the top right where the 3 lines are and I have gone to additional settings and I have selected autofill and then passwords and I have offer to save passwords is turned on. and Auto sign in is also turned on. I have restarted The brave browser. which again I use in private mode or in Incognito mode. and still the same thing happens. Brave is not saving my usernames and passwords or asking me or anything. Any help would be great!
Thanks!!

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

You should save your password in a normal window first, and then you can use it in a private window.
Private mode, by definition, doesn’t save passwords.

Hi, are you saying to get out of incognito mode completley and save the passwords that way? The way I do it is I go and hit the 3 lines up in the right corner of my screen and I click settings and I do it that way as I described in my post. but when I exit brave and log back in to brave using private mode the username and passwords are not saved for Youtube or facebook

  1. Press Ctrl+N;
  2. open the website;
  3. log into the website and save username and password when asked;
  4. close the window;
  5. open a private window (Ctrl+Shift+N);
  6. open the website and log on using the password you saved earlier.

are you saying to get out of incognito mode completley and save the passwords that way?

Basically, yes.

1 Like

Okay I will try this.

Nope still did not work. How do I get out of private mode and get back to regular non private mode?

@Kinnyr900,
What @gmacar is saying is that passwords that are saved in normal windows autofill should be appearing in Private windows for those accounts as well.

Can you tell me what type of device you’re using?

Windows 10 Latest version 20h2 and I’m using a desktop computer Cusstom Built

@Kinnyr900,
If you are browsing using a normal window (not private), visit a website where you have an account – you mentioned Facebook which is a good example but it can be any site – and authenticate into the site, are you asked to save your password? If so and you do so, they then should be stored in in brave://settings/passwords.

Now, let’s test to make sure the autofill is working correctly before trying in Private. Log out of the same site you just saved your login information for. Go back to the login screen and click in the Username field – does the autofill option for this site appear?

Hi yes it works in normal mode but it’s not saving when I go back into private mode. When I first start the browser I’m in private mode if I creat another profile I’m in regular mode not private because I have not changed any settings. so if I go through all of this again it works as long as I’m not in private mode. If I get out the the browser completley and restart it. I’m back in private mode and I go to facebook and then youtube or vice versa but nothing is saved when I go to the settings and additional options and auto fill and passwords nothing is saved in there either so I’m not sure what tyo try next I will keep at it though.

@Kinnyr900,
Perhaps there is a miscommunication here. Can you clarify some of what you just said for me?

How have you configured your desktop browser to do this? There isn’t an option in Settings to do this – did you setup a custom command line tool or alter the target path?

Why are you creating a new profile?

“C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe” --process-per-site --incognito --alsa-output-start-threshold This is what I have for the target when I right click on the brave taskbar Icon.

@Kinnyr900,
Thank you for confirming that. Can you please try removing the flags in the shortcut? Then

  1. Open a normal Brave browsing window
  2. Press ctrl + N or Menu --> New Private Window to launch a private browsing window
  3. Visit Facebook or Youtube in the private window

Does the autofill option for the site appear?

No it does not. It’s okay hey thanks for all your time I very much appreciate it!!

This is a tough one at least for me but I will try and get to the bottom of it.

@Kinnyr900.
Do you have any extensions installed at this time?

Yes I do sao I will temporararly disable them to find out which one is causing the issue if any

Didn’t work thanks anyway.

I got it. If I go to settings and I went to clear browsing data and the on exit tab I had checked to remove passwords and other sign in data Well I had that checked. I unchecked it because leaving it checked was removing the passwords from being auto saved. So thanks again for your help!!

2 Likes