How to save log-in creds after replying "Never Remember"


#1

I must’ve clicked the wrong answer the first time I logged in to my WiFi rooter from Brave browser, because Brave didn’t save the password and now I can’t figure how to convince it it needs to. And I’m getting tired of having to manually log in all the time. It’s remembered passwords from plenty of other websites I use, just not the web interface on my rooter.

The browser is Brave 0.20.30 / V8 6.4.388.40 / rev 8b78402 / Muon 4.7.9 / OS Release 4.13.0-36-generic / Update Channel Release / OS Architecture x64 / OS Platform Linux / Node.js 7.9.0 / Brave Sync v1.4.2 / libchromiumcontent 64.0.3282.119, using the default theme and color scheme. All shields are off for this IP address.

The OS is 64-bit Linux Mint v18.3, 4.13.0-36-generic kernel.

The rooter is an Asus RT-AC68P running v374.43_27E5j9527 firmware, Merlin LTS fork.

I’m connected to the rooter by four feet of beige CAT 6 RJ45.

How can I persuade the Brave browser is needs to remember this log-in?

I know the log-in won’t be in a cookie but I thought the setting never to remember the login might be. Except I can’t test that theory by deleting the rooter’s cookie because I can’t find where the cookies are stored, and there is no setting in the GUI to delete the cookies for just one site.


#2

Hi @MightyFavog,

Here’s the steps.

  • Type about:passwords on URL bar.
  • Scroll to the end of page. In there you should see Never save passwords on these sites: section.
  • Click X button next to URL will remove it. Then, next time you log in again, it should show you the permissions again.

Hope that can help.
Best,
:slight_smile:


#3

I have no “Never save passwords on these sites” section.


#4

I checked my Windows 7 PC, Brave v.0.21.24. It doesn’t have “Never save passwords on these sites” section under “about:passwords” either.


#5

Thanks for the info @MightyFavog. :slight_smile:

Did you see your other passwords for other sites listed there at about:passwords?

Also cc @kamil @LaurenWags


#6

Here’s the entire page (with minor privacy edits):

The about:passwords page in Windows in much the same.


#7

Hi @MightyFavog

It does not look like you can remove this selection this for one site in settings, I have logged an issue for this: https://github.com/brave/browser-laptop/issues/13670

So, that being said, there is a workaround but it’s a bit cumbersome. First you’d want to make sure you have any and all usernames/passwords from about:passwords stored elsewhere for this process. If you have the site open where you selected ‘never for this site’ option, close it. Then go to about:preferences and open Security. Click on the ‘Clear Browsing Data Now’ button. On the popup switch on ‘Saved Passwords’ as below:
52%20PM
Then select ‘Clear’. This will clear all saved usernames and passwords in about:passwords. Next time you go to any of these sites, you will be asked if you want to save your username/password - this should include the site you previously selected ‘never for this site’. Again, be sure you have all usernames and passwords backed up if you do this since this will delete them - exercise caution if doing this.

Lauren


#8

I’m not sure why you not see this section at about:passwords. It shows for me on 0.21.24.


#9

That’s super interesting @eljuno - I didn’t have that before! I’ve cleared my profile and now I do have it. Although, there was a crash when I selected ‘Never For This Site’ so I wonder if something is going on there. I’m going to add info to the logged issue including my crash report IDs and see if someone can take a look.

Lauren


#10

Both of my GUIs are different from that.

In both Linux Mint and Win7, passwords are not listed in browsing data. My GUI on Win7 appears similar, passwords are under a heading separate from browsing data.

Anyway, I deleted all passwords and nothing changed. Except now I have to re-enter all my passwords.

And I noticed I have the same problem in Brave on Win7. It hasn’t saved the PW for the router and doesn’t ask for it when I log in. Which means either I made the same mistake on both systems (different hardware) the first time I accessed the WiFi router or something mysterious is going on.

Anyway, when I get the time I’ll R&R Brave on Mint and see if any thing changes.


#11

I’m happy to see another user of Mint on the forum, I used it a year or two ago and really liked it but switched to Ubuntu due to the better support on everything Ubuntu. I may have to switch back soon now that I’ve got some more experience, but that’s a different topic.

It looks like you’re really close to solving your issue, you simply need to press on the “Manage Passwords” button and then you’ll be on the page @eljuno originally wanted you on. At the bottom of my page I’m also seeing a way to remove sites from the list of sites to not remember passwords on.


#12

I uninstalled Brave, then reinstalled, and nothing changed. It still didn’t ask to remember the PW when I logged in to my WiFi router at 192.168.1.1.

But it still remembered some personalization stuff, and I found the uninstall routine doesn’t delete the folder at ~/.profiles/brave (another matter the developers might want to look into). So I uninstalled again, deleted the profiles folder from CLI, and reinstalled. That time it definitely was a “clean” install because the first time I loaded it it offered the new installation customization pages.

So first thing, without making a single modification to the clean install, I logged in to 192.168.1.1. And it still didn’t ask if it should remember the login credentials.

So I’m left to speculate that either Brave behaves differently when the login is to a private IP address on the local intranet or there’s something hinky going on between Brave and the Tomato-based ASUSWRT Merlin firmware.

And unless I’m very much mistaken, the same thing happened on Brave on Win7, but it will be a few days before I can rip it out and try the login from a clean install.


#13

Or maybe I didn’t click ‘do not remember.’

I’ve removed the Brave installation in Win7, including the directories in the user profile, then did a clean install. Then I rebooted and first thing loaded Brave and logged in to 192.168.1.1. It never asked to remember the password. Went to password management and it reads ‘no passwords remembered.’ So it looks to me like this isn’t a ‘bug,’ it’s just the way it’s written.

I log in to my router pretty much daily checking logs or editing IP tables ans such, so it would be handy if it were to remember the login.


#14

The plot thickens.

I bought a LinkSys EA6350 AC1200 router for my brother. He’s tech illiterate so I offered to pre-configure it for him. When I log in to it (wired) at 192.168.1.1 using my Win7 PC, one of same PCs I’ve had the problem with on my ASUS router, it asks to and does remember the login.

So it appears there is something strange going on between Brave browser and the ASUS router’s firmware. The OE ASUS firmware is AsusWrt-Merlin, which is a fork of Tomato, but my particular router is flashed with a fork of Merlin that was modded by John Bacho. I lack the motivation to flash my router with the OEM Merlin firmware to determine whether the same would happen with it, but for future reference, his firmwares can be identified by the last five characters of the version number, which is always j9527 (his screen name is john9527). My firmware version is 374.43_27E5j9527

So if it’s down to that small a user group, my guess is the noise level on this is too low for Brave’s developer’s to be bothered with (at least until John Bacho takes over the IT world).


#15

I got a new PC, put Linux Mint 18.3 on it and loaded 64-bit Win7 on the hardware I had been running Linux on. Clean installs in both cases. And the Brave browser I installed on them both do the same as before. Neither offers the option to save login credentials when I log on to the Asus router running the Bacho fork of Tomato.