How to remove Brave Lens?

Found it. It appears when you are using google search. Both of us were using some other search engine, while these guys were using google.

When you right-click on an image, the brave lens/google image thing appears.

1 Like

Hmmm, still not working for me. What I did and tell me what I need to do. :stuck_out_tongue_closed_eyes:

  1. My default search is DDG. I went to google search in an NTP, searched for an image, right clicked, and nothing.
  2. I changed my default search to Google. Repeated steps and nothing.

What am I missing!!?? lol

Edit: May be something in settings… with DDG as default browser, google search/images looks like this

When I repeated using a Test Profile that has very little setting changes and I repeated using a private window, this is what it looks likes in both instances

Still not getting anything when I right click an image though in any of those.

See

OK, so this is weird, when I opened a private window, this is what I see. The search bar is like on my default window now and doesn’t display the one I had in the previous private window… weird.

OK, if I open a private window using the test profile I get the different one. ugh.

Still no “Search image with Brave Lens” in either.

I have fixed this problem in chrome by just disabling that “enable-lense-region-search” but the same is not working on brave and I mostly use brave so how to fix it cause google lense really sucks and give less efficient results than image search.

@okok Hi and welcome to the community. :slightly_smiling_face:

@MichaelMaus Said he tried that in brave://flags and it didn’t work for him. I don’t know if he tried in chrome.

You might give it a try and see if it works for you since it worked in chrome (the below image was copied from post #4 above).

Getting the “Search image with Brave Lens” in the context menu with google search now. I left google search as my default browser, exited the browser, and when I opened it back up it started working. Now when I change my default to google search it always appears and works even if change back to a different search engine, closing browser and opening it again (it wasn’t doing that before).

1 Like
1 Like

i have tried it in brave but it doesn’t work even after relaunching the app.

1 Like

@okok OK. Wish it had worked. :disappointed_relieved:

@aman_m Cool. Wonder if this thread prompted someone to open an issue report. hahaha I think other users on reddit were posting about the same thing. I’m glad it caught the attention of someone who participates in Brave GitHub.

Take care all. Hope the issue is resolved to your satisfaction.

1 Like

I just noticed this switch Brave did from Google image search to brave lens today & was pissed. They never asked me - they just did it. The reason I switched to Brave, to begin with, is that they didn’t appear to force crap down your throat like the other big platforms. They don’t reverse this quick or offer me the option to switch back - I will be giving Brave browser the boot quick here. I wouldn’t mind if Brave Lens was as good a product as google image search, but it’s not. It sucks.

3 Likes

This is really annoying but you can still do it with 2 extra steps:
1- search the image with brave lens
2- scroll down and press “view all”. Make sure the entire photo is selected
(This “view all” doesn’t always appear, tho)
3-You’ll be sent to the second page for some reason so scroll down and go back to the first page

I hope it helps (and i hope they fix this)

1 Like

@rodrigoaafn Hi and welcome to the community (I love saying that! lol) :smiley:

Ditto. Thanks for posting a work-around even if it is a pain. lol

In all sincerity, thank-you again. :smiley:

1 Like

Hey y’all. Found this thread because I hate the change as well. Per @rodrigoaafn 's tip to scroll down, I found that there’s actually a place that says basically, “Bummer, didn’t find what you want? Try again with Google Image Search.” Screenshot attached.

Now a one-step process is a two-step process (three if you count scrolling to the bottom of the results) and I still want them to provide the option to switch back, but at least this is a workaround.

image

Disabling it in flags does not disable it (at least since recent update), brave has even rebranded Google Lens as ‘Brave Lens’…they enable it without asking, really trustworthy of them.

1 Like

Unfortunately this didn’t worked, I saw some other comments saying that it’s because I’m using google as my search engine, but here’s the thing: Chrome had implemented lens waaaay before this change happened on Brave, so it really seems like it was Brave’s devs decision to implement brave lens, and not because I’m using google.
It’s a shame, brave was becoming my favorite browser of all time until this, I hope this thread gets enough traction so maybe the devs will revert on their decision. I’ve yet to meet a single person on this Earth who likes google lens.

Just so y’all know, if you haven’t figured it out yet, this was an error by Brave. They use Chromium as the base and convert a lot from a Chrome into the browser. As such, they essentially do a “find and replace” in code to replace Google with Brave. Unfortunately they messed up on Lens, having converted the word for it in the toolbar. They also messed up on some versions of the browser to say Brave Web Store when talking about getting extensions, even though it still takes you to Chrome Web Store. Also searching with “Brave Lens” still takes you to Google Lens. As said, just was a bad mistake on their part where words were changed but not the actions associated.

It’s all still Google Lens and all, just coding changed the words Google and Chrome.

Developers said it’s a branding issue and they are moving to correct it. Until then, it’s basically just a glitch where we see Brave when it really means Google. It’s dumb and they need to be more cautious in the future. But yeah, that’s what it is for now

Yes, most of us thought the Google vs Brave Lens was a branding issue from the GitHub issues post where it was referenced. Many of the posts on reddit also referenced the same.

However, the major problem is that most (probably all?) do not like Google (Brave) Lens and want to go back to Google Image Search. Currently, with Chrome update 99, they do not have the option to turn Lens off and return to their preferred use state.

Currently it appears only “workarounds” and extensions are the only options. While useful, these options are not ideal and some do not work well. Most want to have Google Image Search back or at least the option to choose.

P.S. I posted about the Chrome 99 issue in two different posts in the other topic per Lens.

For the sake of closure, this silly change was finally reverted a few days ago. Thanks!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.