How to hide TOR icon next to sheilds

How do I hide it??
I want to have TOR window option available in hamburger menu, but not Open in TOR next to shield when I go to website which also has onion website available (like brave.com)

The answer given in reddit comment section is not correct (is bogus).

Also, I searched flags and there is nothing related to solve my problem.

@chh_68 Yeah. It’s not trivial. It appeared after I toggled on Automatically redirect .onion sites but remains after toggling it off. It can be made to go away after disabling Private window with Tor on brave://settings/extensions and a manual relaunch.

1 Like

Nada.
I want TOR window option in the hamburger menu (top right hand corner) where you can see new private window with TOR but I do not need the Open in TOR option next to brave shields icon on the URL/Address bar.

@chh_68 Did you try disabling Private window with Tor first and relaunching to see if Tor option in the url bar goes away?

You can always re-enable Private window with Tor.

When I disable Private windows with tor, the tor option in Url bar does go away.
But, doing it also makes Private Windows with tor go away, but I do not want.

I want Private windows with tor, but I do not want tor icon in url bar which currently is not possible. Brave devs will need to work on it.

You can always re-enable Private window with Tor.

But doing it brings back tor option in url bar, which I do not want. I only want Private Window with tor in hamburger menu.

Strange, it doesn’t come back for me. Did you relaunch after disabling it first?

Strange, it doesn’t come back for me. Did you relaunch after disabling it first?

It will not come up directly after changing the settings, as you are on default chromium pages where onion URL is not available. You need to go on specific sites where normal URL along with Onion URL is available like brave.com. Here if you Turn ON Private Window on TOR after disabling it and relaunching it by infinity it still does not solve the problem.

Yeah. My bad, you are right. It does come back after re-enabling Tor. Will have to tag @Mattches for support.

1 Like

I do not think there is a way to do this at this time. I’ve reached out to the team to confirm.

1 Like

I too think there is no way to do it.

The official tor browser (from tor project) also has this open onion site near the URL. But, there is a settings which says, ‘always open onion links’ instead of ‘ask to open onion links in new tab’ which sopves this problem.
So, if I go to brave.com it automatically opens brave onion site, so there is no chance for the onion option to appear in URL bar.

@chh_68,
You can stop that behavior in Settings --> Extensions

I know about this feature, but the problem for me is that I use some websites that also have .onion websites linked to their clearnet/normal websites. So, to use these websites I need to be logged in via cookies, so I cannot automatically redirect them to .onion sites which are in private window with no cookies.
But, on official tor browsers, I (and other users) specifically use the tor browser just to surf .onion sites only, so by using the above feature ‘automatically redirect’, you can remove the ‘open in tor’ button in URL bar in tor browser.

It is something like paradox for me. Hard to explain.