How to force Brave to open bookmarks in new full-size window?

I am new to this browser. Recently the behavior of opening a bookmarked tab or folder full of bookmarked tabs in a new window seems to have changed. Before, the tabs would open in a new, full-sized window. Now tabs open in a new window that is very small (minimized). I have to click to maximize the new window. This is slightly annoying. More annoyingly, I can’t find any way to change this behavior so the new window opens full-sized. Is there a Firefox-style about:config page I can access? Or something?

Steps: Click on bookmarks extension (“Popup my Bookmarks”), hover over tab or folder, right click to invoke menu, select “open in new window” or “open in incognito window,” click to open. Tabs open in a new minimized window. … To check if it was the extension, I tried using the default Bookmarks Manager — same behavior.

Windows 10, desktop PC. [Version 1.16.75 Chromium: 86.0.4240.193 (Official Build) (64-bit)]

Thanks for your help.

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

I may be misconstruing what you’re saying, but I believe that window size should be remembered. So if you manually resize a window in the browser, opening up a new window should open one at that same size.

This is the behavior I see on my end when I try to open a bookmark in a new window. Note that you can do this by right-clicking and selecting Open in new window from the context menu, or by holding Shift as you click on the bookmark.

But you’re saying that when you use either of these options, it will open the bookmarked page in a new window, but the window starts minimized, is that correct? Would you be willing to share a very short screen recording of the behavior?

Thanks for the quick comeback. You are not misconstruing. The window size is not remembered. Basically I would like the default to be “open bookmark(s) in a new maximized window.” I think it did work that way when I first started using Brave. Something changed.

I forgot to mention, perhaps it’s understood, that this behavior occurs when opening a bookmark in a new window using the context menu, from a maximized window. I tried “shift” too and got the same minimized result.

You prompted me to discover that: if I open a bookmark in a second window, resize the window, then open a bookmark in a new window from the resized window — in this case it opens the new window the same size (almost) as the resized one. However, it does not remember the resizing once those windows are closed.

I suppose one workaround would be to make a resized window the starting point of my session, resize it to full-ish screen, and use that as the basis for all further new windows during the session. But … ugh.

What app do you use to record screen behavior?


Sent using Zoho Mail

I would personally suggest ScreenToGif – we also have a list of other (free) tools you can use:

Neat program. I have attached a gif. Hope this helps. George

Sent using Zoho Mail

I’m sorry for the (very) late reply – just by chance I happened to go on my PTO the day after responding to your message.

This may sound strange but, if you’re still facing this issue, can you try creating a new browser profile (Menu --> Create Profile) and see if new windows open in the same way?

No problem. For some reason, at present, it opens in a nearly full-sized window. I thought you’d fixed it. Not sure what changed. Thanks for the comeback.

Sent using Zoho Mail

1 Like

No problem – please don’t hesitate to reach out if the issue persists :+1: