How to enable strict site isolation on Brave (chrome://flags#enable-site-per-process doesn't work)


#1

Hi,
due to Meltdown and Spectre bugs (https://meltdownattack.com/) Google recommend to enable strict site isolation. In Chrome it can be done by: chrome://flags#enable-site-per-process
Brave is based on Chrome so I tried type chrome and brave but it doesn’t work.
How to enable strict site isolation in Brave ?


Brave Protection from Meltdown/Spectre?
#2

Hi @Thorwald

We have an issue logged for this: https://github.com/brave/browser-laptop/issues/12490 and plan to release a new version soon with this fix.

Thanks,
Lauren


#3

It appears you can enable site isolation by launching Brave with a command line flag.


#4

Hi @alwillis
Unfortunately, running with these flags causes that LastPass does not work. After removing the flags, LastPass works. Since I can’t do without LastPass, I will wait for a different solution to the problem.


#5

Hopefully you’ll have better luck with the hotfix @LaurenWags mentioned, although some extensions may break until they’re updated regardless of how site isolation is enabled.


#6

This is a great point @alwillis - the likelihood of breakage is high. Thanks for mentioning it.

Lauren


#7

Just got in from a little exercise; saw that Brave v0.19.127 got released while I was out—it has the site isolation hot fix; go to about:preferences#security to enable it.


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.