How to enable flags without using the local flags page?


Error code: STATUS_BREAKPOINT
How can this issue be reproduced?

  1. By disabling the Brave://flag “Latest stable JavaScript features”

Expected result:
All local Brave webpages no longer respond, throwing error code: STATUS_BREAKPOINT

Brave Version
Version 1.28.106 Chromium: 92.0.4515.159 (Official Build) (64-bit)

Additional Information:
Does anyone know how the heck to reenable the flag “Latest stable JavaScript features” if the access to the local flag page no longer works?
See OP; Can't access local browser pages - #18 by Mattches?
and the solution by babok: “By enabling the Latest stable JavaScript features flag”

@new11,
Go to your Brave shortcut on your desktop and try the following (if you don’t have one I would make one, as this is the simplest solution)-- the process below looks a lot more complicated than it actually is :slight_smile:

  1. Right-click on the Brave desktop shortcut you just made, then click Properties.
  2. In the Target field, after the closing quotation type --no-experiments. This should make it so the browser launches without running any modified flags in brave://flags.
  3. Click Apply then OK then launch the browser.

Now you should be able to view the browser’s internal pages again. Go to brave://flags and set the flag you changed (“Latest stable JavaScript features”) to Default. If it is already set to default for some reason, I would set it to Enabled to be safe. Relaunch the browser when prompted and make sure the flag is set to the correct value. Close the browser.

Now go back to the shortcut you edited and take out the modifications you made to the shortcut path, Apply,OK, launch the browser and you should be good to go.

Let me know if this works for you.

3 Likes

Genius, thanks! :slight_smile: extra words to make up the 20min

1 Like