How to disable the make brave default nagging?

Description of the issue:
Whenever I start brave I get a banner saying it’s not set as my default browser, which is very annoying. Even pressing the “Make default” button won’t make it go away.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Open Brave, see the annoying banner.

Actual Result (gifs and screenshots are welcome!):

See banner nagging about brave not being the default browser.

Expected result:

Not see that banner after the first time it’s dismissed.

Reproduces how often:

100% of the time

Operating System and Brave Version(See the About Brave page in the main menu):

Ubuntu 22.04
Brave 1.46.144 (installed via flatpak)

Additional Information:

I’ve seen a few threads on this topic, but all of them someone said the problem was fixed in a newer version (I’m in the latest version though, and the version at the time people said the problem was fixed was way older than mine).

Have you gone into the Ubuntu settings and change Brave to be the default browser there?

I have, but I figure that, even if I didn’t want brave to be the default (the current setup is working for me anyway), I should be able to permanently dismiss the banner. Is there really no flag anywhere to disable that?

There’s not one that I’m aware of.

Turns out that clicking on the X rather than “Make Default” makes it go away forever. It really should be an option. Anyway, the feature seems to be broken in ubuntu 22.04 + flatpak as the browser is incapable of identifying that it is the default and clicking on “Make Default” doesn’t actually do anything.

I think it’s unable to run xdg-settings:

LaunchProcess: failed to execvp:

However, if it was able to, it would see that it’s the default browser.

What about running it as a .deb file and installing it with gdebi or another install process?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.