HOW to disable brave wallet ? Like forever?

The wallet is so annoying. We need the function to completely disable it.

I chose in setting to connect to the extension wallet, but the website keep going to give priority to the brave wallet. ITs like brave forcing to connect to the brave wallet .WTF Anyway just migrating to the google chrome back

1 Like

You can disable by going to brave://flags → Search for flag ‘Enable Brave Wallet’ → Change Flag value to disabled.

1 Like


I finally got Brave exactly how I liked it and then the brave wallet would always override my MetaMask wallet even when I clicked “connect to metamask” and even though I had “extension” (for wallet) selected in preferences (as opposed to Brave wallet), and it was driving me insane.

This is a bug that needs to be fixed, but, for now, your workaround/hack has made Brave usable for me again, and, for that, I am very appreciative.

It’s my favorite browser and I would hate to have to go back to using Chrome, but I was on the verge of doing so, and I’m very relieved that I do not in fact have to.

Glad that I was able to help!
@sampson you might wanna have a look.