How to disable brave crypto wallet

its getting in the way, it prevents from working properly… it works properly on firefox but not on brave


it doesn’t work, uniswap and like every dapp is still broken

back to firefox i guess

Hi, Just so you know, I am new to crypto and Brave. l am just posting to see if I can learn and gain some understanding about how things work because I stay confused most the time! lol You guys can respond or not, no problem. :smiley:

Since I really don’t know how to ask the questions I have, I’m gonna make it short and vague. :wink:

Does this issue have anything to do with adding custom networks and wallet extensions?

### Additional wallet settings
On the Accounts tab, you can click the “gear” icon to adjust the browser’s wallet settings and behavior (you may also get here by going to brave://settings/wallet ).

Default cryptocurrency wallet - Use this option to set the default wallet the browser will use when interacting with dApps while browsing:

  • Brave Wallet (Prefer extensions) - Select this option if you have a Brave Wallet created, but want sites to default to using a different wallet extension, such as MetaMask for dApps.
  • Brave Wallet - Select this option if you want dApps to use your created Brave Wallet.
  • Crypto Wallets (deprecated) - Select this option if you elected to use the old Crypto wallets setup rather than the new Brave Wallet implementation. Depending on your installation, you may not see this option.
  • None - Select this option if you do not want sites/dApps to interact with any installed or created wallets.
    Default base currency - Choose the currency you wish to view asset value in when using Brave Wallet. This is set to USD by default.
    Default base cryptocurrency - The currency by which you compare all other currencies.
    Show Brave Wallet icon on toolbar - Choose to show/hide the wallet icon on the browser’s toolbar.
    Automatically lock Brave Wallet - Choose how long it takes (in minutes) for the wallet to lock while inactive.
    Networks - Add custom networks for the wallet to transact on.
    Reset Wallet - Reset Brave Wallet. Note that all data will be erased (including any accounts/held assets) when selecting this option.

Why isn’t my MetaMask or other extension not working with Dapps?
Dapps work by communicating with a special object that Brave Wallet and extensions like MetaMask provide named window.ethereum. Only one wallet can provide window.ethereum to websites. In Brave, we expose a setting in brave://settings/wallet to be able to change which wallet provides window.ethereum. Here’s a description of each setting:

  • Brave Wallet (Prefer extensions) - This is the default. Brave Wallet will expose window.ethereum but allow other extensions such as MetaMask to overwrite it.
  • Brave Wallet - Exposes window.ethereum and prevents sites and extensions from changing window.ethereum .
  • Crypto Wallets (Deprecated) - Gives access to the old deprecated wallet. This option is not compatible with other extensions such as MetaMask.
  • None - window.ethereum will not be provided by Brave Wallet at all. If you have extensions such as MetaMask, is is free to use window.ethereum .

After changing the default wallet, it is best to restart your browser. Why?

  • If you had Crypto Wallets loaded, it won’t be unloaded until the next restart. When Crypto Wallets is loaded it will not work properly with other extensions trying to access window.ethereum .
  • Existing already opened tabs will not change to use the new wallet setting, you need a new tab or a browser restart.

I think my main questions are: In this instance, would adding Avalance as a custom chain help resolve the issue? or has that already been done and it is understood?

1 Like

Have you tried disabling extensions, resetting the wallet (make sure funds are backed up first!), checking that this deleted any custom wallet networks (if you added any), then setting Default cryptocurrency wallet to none, and disabling Show Brave Wallet icon on toolbar, before re-enabling extensions?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.