How to delete URL recommendations


#1

How do I delete the URL recommendations when I type a word in my browser URL box? For example I type you expecting YouTube but it gives me yourstory.com a site I accidentally visited once and have deleted from history, but it still stays around in the URL recommendation


#2

Per the posting guidelines please provide the requisite info so we can investigate in an efficient manner.

Thanks!


#3

I deleted this site from my history but it still pops up as first recommendation after i type “you” in url bar


#4

Could I know if you have bookmarked of the page?


#5

i did not, it just lingers in the recommendation box for some reason


#6
  1. Tell us your Brave version.
  2. Tell us your operating system version (Windows 7, OS X 10.11.6, Ubuntu 16.04 for example).
  3. Tell us the Shield settings you have for the particular site (click on the lion icon in the upper-right to find out).

#7

OS X yosemite 10.10.2

newest brave version


#8

when can I expect a solution? thanks


#9

That issue is due to that only 500 entries are displayed (while stored) there because of performance issue. The issue is recognized (but unresolved yet) by the team and you’ll be able to delete the domain from the URL bar autocomplete. Thanks :smile:


#10

when can I expect a fix?


#11

I am a similar/same issue. Every time I go to type in “amazon.co.uk” it always has “Amazon.com” at the top and assumes that is the site I want to visit, which it isn’t.
It would be great if I can highlight it from the URL suggestion drop-down, and either right click, or hit the delete key on the keyboard to remove it from my entries until I next visit it.

I would have thought that the top of the list would be the more frequently visited sites as well. So I only ever visited the .com site once by mistake, but I visit the .co.uk daily it would be a nicer UX if the .co.uk was the top of the list instead of the .com.

Many thanks.


#12

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.