How to delete alert "To get future Brave updates, you'll need macOS 10.13 or later."?

I want to install Brave on a 2008 model MacBook, running Mac OS X 10.11 El Capitan (the latest version it can run). It won’t run the latest Brave, so I had to find a version that will run.

So far as I can tell, there’s no way to get old versions of Brave from Brave’s own download page? Nor is there any way to determine which version is needed for El Capitan. If there is, I’d like to know about it. So I had to go hunting around the Web, finally found a bunch of old versions at, and by downloading several, found that the latest Brave that will run in El Capitan is v.1.41.100 - Chromium 103.0.5060.134. (It’s Chromium 104 that demands macOS 10.13 High Sierra.)

So I installed that version in the MacBook. However, when it opens, it always shows an alert: “To get future Brave updates, you’ll need macOS 10.13 or later. This computer is using OS X 10.11.” Yeah, I know that. I click on the X to the right to dismiss the alert, but when I reopen Brave the alert is there again.

Can anybody tell me how to dismiss this alert, so it won’t keep appearing in windows/tabs?

You would need to look through to find the version you’d want to download and can do it from there. Use the search box to help narrow down between types of releases.

This version of Mac lost all support back around October 2019. So it’s been a little over 3 years since nobody supported it. Really should be upgraded. Means you’re way behind on security and all. You’re open to many vulnerabilities.

Well, you could have searched for it. Quick search here found someone else who asked and had answer given to them last years. HELP! What version of brave for Mac El Capitan 10.11.6. It also was the #1 result on Google.

There’s no official way to get rid of it. I know on Windows people have found ways to change Registry. I’m not familiar with Mac on how to do it. But idea is they don’t want you using it and it’s not supported. It’s going to appear each time to make sure you or whoever is using the browser knows that the browser is vulnerable to hacking, viruses, etc and that it’s not supported, meaning many features may be missing or broken. Not to mention performance would not be as good.

Thanks for your response.

Looks like all releases of Brave are listed on this page? Only a search for 1.41.100 finds nothing, though that is a legitimate release (not a “pre-release” as most of these seem to be). There is a 1.41.1 listed, but it’s a “pre-release”. What I was looking for was a list of actual release versions, with system requirements, so I could tell which would work on El Capitan.

Yes, I know it’s an old version. It’s the latest version that will run on this 2008 MacBook, which I keep around for occasional tasks like using old software that won’t run on my newer MacBook Pro, where of course I am using the latest Brave. And on my friend’s 2008 iMac, which is what got me into this as I’m trying to help him with something. He doesn’t use it much, and it does what he needs, so why spend a lot of money for a newer one? The relentless upgrade treadmill gets old after 38 years.

I’ve been using the Mac intensively since 1988, and I think I’ve seen maybe one “virus”, ca. 1990, that was harmless. And I’ve had to deal with “ransomware” attacks a couple times, again years ago. I know the Windows world has a lot more such problems, but in all I don’t see the reason for the general panic about “security”. They’ve got everybody so terrified these days they are getting away with literal murder.

I did look at “HELP! What version of brave for Mac El Capitan 10.11.6”, but didn’t see what I was looking for. Looking more closely, I see somebody posted: “So builds of 1.41 would be needed:” Only, as I know from my own research, that’s not the last version that works with El Capitan, which was v.1.41.100.

I remember seeing this before, a year or so ago when I first installed Brave on the 2008 MacBook. I think maybe the alert just got tired and went away after a while. I looked through Brave settings but didn’t find any way to turn it off. I’m hoping somebody might know.

My friend, who is not much computer savvy, told me his iMac has Brave v.1.41.100, while my MacBook had v.1.33.106. I wondered why mine had not automatically updated, which got me started on trying to figure this out. Does Brave come in different versions for desktop and laptop use? Apparently not, once I found v.1.41.100 and downloaded it and it ran fine on the MacBook. When I tried to update the v.1.33.106 on the MacBook, I ran into the expired certificate mess, which is a whole other hassle. I remember encountering it before, but don’t remember how I worked through it.

Anyway, maybe somebody knows how to turn off the “update to 10.13” alert in macOS?

Yep, and it takes a lot of time to sort through them sometimes.

First and most importantly, that’s because there was no 1.41.100. It went from Release 1.40.113 → Release 1.41.93 (which has Pre-Release written beside for whatever reason) → Release 1.41.94 (Pre-Release) → Release 1.41.95 (Pre-Release) → Release 1.41.96.
Guessing the reason you had link to 1.41.96 is because that is indeed what would have been the last.

Exact searches don’t often work as well as they should. It’s actually something should ask @Mattches to look into as just typing in 1.41 should show all versions of 1.41.xx but you’re right, using that example it just loads Nightly of 1.40.1

Have to go page by page by page. Which is what I just did to find it for you. Keep in mind I’m just another User and not paid for this. Ideally it would have been you who took the time to look for it in the same way I just did. (Though as I said in bit above, Brave should have it easier to search/sort)

Umm, so you saying you tried 1.41.96 and it’s nor working? If so, have to go back to one of the older, such as the last prior would have been 1.40.113, which is

Also not sure where you’re saying your own research is from? Any link from that?

Btw, closest to 1.41.100 would be Nightly 1.41.2, which is

Dev went from 1.40.97 → 1.41.69
Beta went 1.40.100 → 1.41.71

Well, I found one here: Dunno why they have only this list of old versions, but saw it included 1.41.100 (as well as 1.41.96), and knew wouldn’t work, so figured 1.41.100 was the one I was looking for. Never did try 1.41.96. And it seems to work okay. Here’s what the About window says:
Screen Shot 2023-02-06 at 4.48.05 PM
Thanks again.

I’m a little confused here — it looks like you’re running the version you want (1.41.100) in your last screenshot. Is there something wrong with it? Further, that alert will in About Brave will not go away regardless.

Yes, I’m now running v.1.14.100. Which, as I explained, I found on my own, as it doesn’t appear to be in Brave’s list of versions – though my friend has it on his iMac, which alerted me of its existence.

Yes, I don’t expect the alert in [About Brave] to go away; that doesn’t bother me. What I’d like to go away is the band in the window (below); I’ve seen it once, don’t need to see it again. It just takes up space, to no useful purpose. I can click the X to dismiss it, but then it reappears every time I start Brave. Is there some way to stop it?

I had assumed that this banner would dismiss permanently after being closed out. I’m asking some team members about this now — if it does not, I will suggest we include such an option, especially since the message is still displayed on the About page.

I’m not sure how you found that version either now that I’m looking. Can you tell me where you found/downloaded this version?

They had mentioned Filehippo and linked it.

It is concerning that it shows like it was all released today though. Guessing not legitimate and might have some sort of virus or trackers built in or something?

@Saoiray thanks I missed that link above. @ElectricBrain I would highly recommend using our official Github repository to download any version you’d like to use. Further, I don’t know why I couldn’t find it a bit ago but I just searched again and was able to find it right away — looks like it was an official release as well:

Nice. I know I went through tab by tab and didn’t see it. So not sure where I missed.

Btw, is there a good trick to sorting through all of that? Because when trying to such through like 1.41.100 all it seems to search is the 1 but not anything after. Example below:

Or if I try "1.41" it comes up:

If you are looking for a specific version number (and you know that number), you can use the URL

And then just add tag/[version number here]

Hmm. My friend running El Capitan is not a computer-savvy type, so the only way his iMac could be running Brave v.1.41.100 is if it was downloaded automatically by Brave. So it’s a mystery it’s not in the repository.

Yeah, that dating thing is weird. I also found Brave 1.41.100 for download at But for some reason when I clicked the Download button, nothing happened. So I searched further and found the FileHippo version.

I just tried the download from uptodown in Chromium, still nothing. Tried in Safari (v.13.1.2, in macOS 10.12 High Sierra), downloaded fine. But the download was a .pkg file, which runs an installer; I prefer the .dmg file. Tried in Firefox, also worked. Puzzled.

I just put the Brave v.1.41.100 I got from FileHippo on my MacBook Pro running 10.13 High Sierra, opened it, and did a scan with Malwarebytes (which doesn’t run in 10.11 El Capitan), which found nothing suspicious. Not that that covers all malware possibilities, of course.

Sure, I’m happy to run the official one from the repository, now it’s been found. Downloaded, URL saved.

I just tried
but got a 404.

Oh, okay: tried with “/v1.41.100” instead of “/1.41.100”. That worked.

Maybe it does go away permanently after a while. I don’t think it was showing on my MacBook before I updated Brave to 1.41.100.

Anyway, now it shows every time I open Brave (maybe a couple dozen times now with the new version), though only on the initial window; the next tab doesn’t have it, and a new window doesn’t have it. I click on the X to close the alert, Quit Brave, restart it, and there it is again.

Okay, just installed the official 1.41.100, after removing ~/Library/Application Support/Brave Software, so everything’s fresh. Start Brave; the alert appears, but not in a second tab, or new window. Click X to dismiss it in the initial window. Quit Brave, restart. There it is again. Same behavior.

If I click the X to dismiss the alert, then close the window, with Brave still open but showing the desktop behind, then open a new window, the alert is not present. But then Quit Brave, restart, and the alert is there again.

There’s also an Import Bookmarks prompt, though that does seem to go away after a while.

1 Like

I will try and urge the team to release a fix for this (the banner not going away) but I believe it is unlikely that they will implement this fix. I’ll leave this thread open and let you know what they say.

Well, thanks for your concern. I don’t guess it would be a big priority to fix an older version of Brave, but it would be nice if I could just turn that alert off. I know how to do “Show Package Contents”, if there is something I could just delete. Or something that could be toggled in Terminal?

Further experiment: I started my 2008 MacBook from an external HD with El Capitan, which still has Brave v.1.33.106, as was on the MacBook before I replaced it with v.1.41.100. This Brave starts without the alert, as I remember it did on the MacBook before I replaced it with v.1.41.100.

And in About Brave, it says “Brave is up to date”, though – as I discovered when I looked into why my friend’s iMac running El Capitan has v.1.41.100 – it is not, and was not on the MacBook (though it said it was) until I manually replaced it with v.1.41.100.

When I click on the “Version 1.33.106 Chromium 96.0.4664.110 (Official Build) (x86_64)” line (which is a link though it doesn’t look like one), it goes to the Brave Release Notes page (, which offers download of the latest v.148.158 (Feb 7, 2023), which of course wouldn’t run on the MacBook. (Doesn’t say anything about updating to the latest Brave that will run on the MacBook.)

Another curiosity (separate issue): When I start Brave by clicking on a url file (or dragging the file onto the Brave icon in the Dock), it opens that page, but then opens a second window over it with the New Tab page (that appears when Brave is started on its own). This happens with both versions of Brave, whether running in the MacBook or on the external HD. I see it also happens on my spare MacBook Pro with the latest Brave version, so I guess it’s SOP? Hadn’t noticed it before, as when I start Brave on my primary MBP it always has a bunch of windows to open from the last session.

Hmm. I just did this again on the MacBook: dragged a .webloc (url) file to the Brave icon in the Dock. Brave started, briefly showed the New Tab window (with the usual alert discussed above), then that disappeared and the page of the URL I’d dragged onto the icon remained as the only window open. Tried again with another .webloc file; same result. So now it’s working as expected, as it wasn’t before, though I don’t think I did anything different. Tried again on the MacBook Pro as in the previous paragraph, and it again opened the .webloc URL, then another blank new window on top of it. Well, either way it works, I guess. My head is spinning.

UPDATE: My friend with the iMac running 10.11 El Capitan and Brave v.1.41.100 says yes, he sees the alert every time he starts Brave – presumably since last July, when the 1.42.x versions appeared, requiring macOS 10.13. (Uptodown lists a 1.42.86 and 1.42.88, and FileHippo lists 1.42.88; but neither of those can be found at the GitHub repository?) So it’s not just me, anyway. He just dismisses it each time it appears, but it has never stopped – as it somehow did on my MacBook with v.1.33.106.

(I tried to add this paragraph to the previous post, by clicking on the little pencil icon, which opened an edit window; but I couldn’t do anything to the text in it. Why is there an Edit option if it doesn’t work?)

Btw, I’m also using Brave on my iPad Air, which is limited to iOS 12.5.6, so it’s Brave (iOS) v.1.24, as the next version requires iOS 14. However, it doesn’t have a persistent upgrade nag. Be nice if the macOS version didn’t either.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.