How to clear typeahead logins?


#1

There’s a website that immediately displays the full login ID in a pop-up when I start typing it to log in.

It can then be clicked on as an alternative to typing it in full.

I don’t want that to happen but haven’t been able to figure out what needs to be done to clear the typeahead text and prevent it from re-appearing.

Anyone know?


#2

No replies, so in case not clear:

• I enter the URL for a website that requires a login ID.
• When I start typing the login ID it appears in a pop-up.
• That entry can then be clicked on (as an alternative to continuing to type the rest of the text of the ID).

I want that not to happen – i.e., I want to just type in the login ID myself, without any ‘help.’

I haven’t so far been able to find the source that that ‘typeahead’ is coming from.

Clearing cookies (in Brave) had no effect.

Thus my question.

Thanks.


#3

Hi @mk7z,

Which version that you have? And on which platform?

Thanks
:slightly_smiling_face:


#4

@eljuno Thanks. It’s: v. 0.55.2 Chromium: 70.0.3528.4 (Official Build) dev (64-bit) on Mac (OS 13.9.5).


#5

Is it only the username suggestion? And not the log-in credential (clicking on it will also fill the password – from Brave built-in password manager) right?

I think you should clear the Autofill form data. cc @Mattches


#6

@eljuno @Mattches

No, I’m not using a password manager.

Only the username is suggested, as I assume it always would be when not using a password manager.

Where aside from cookies is website login information stored that can result in suggested entries being displayed when you start typing that website’s login info?

The website itself doesn’t appear to have any option for that, so I’m assuming it’s in the browser.

Thanks.


#7

@mk7z Did you already try this? :point_up::slightly_smiling_face:


#8

@mk7z, I think @eljuno is correct. Seems like standard form data needs to be cleared. Also, even if you’re not using the built-in password manager, you may have saved just the username which may appear in the Passwords section.

I’d suggest trying what @eljuno suggested first (Settings --> Privacy and Security -->Content Settings -->Clear Browsing Data --> (Advanced) -->Autofill Data). Then, return to the website and see if the name is still pre-filled. If not, enter your username/pass as normal and elect not to save them. Check Passwords again and ensure the credentials don’t appear there.

You shouldn’t see it appear anymore. If you do then there’s something else afoot and we’ll have to dig further into it. Let me know what you find out!


#9

Thanks.

– Autofill Data was already unchecked.

– I ran Clear Browsing Data on ‘Passwords’ (again, as I had already done that prior to posting about the issue).

– When I tried logging in to the site the same occurred. The login ID pops up in a dialog box (as do two others with errors – i.e., from failed logins because of typos) as soon as I click into the Login ID field (box).

There is an option to “Remember this login information” but it’s not checked.

I’m not experiencing this with any other website but the website has no options for saving passwords, etc.


#10

Sorry but just to confirm, its only happening on one website, not widespread?


#11

Yes, whether by coincidence or not. That is, most websites don’t pop up suggestions just from clicking into a login ID field/box.

The website offers two logins, one completely numeric and one using a standard user ID. I typically use only the numeric one but logged in with the user ID to see what would happen. Now that appears in the pop-up, also (i.e., in addition to the other 3 ‘suggestions’).


#12

I’m 99% sure I know whats happening, but would you mind sending a screenshot just to make sure everyones on the same page here?


#13

Yes, but as a first step can you recommend an online tool to blur text in a screenshot? (I’ve never had to do it.)

One of the mentioned error strings contains both my login ID & password, which is one reason I wanted to delete it.

The others have my login ID which I’m also not eager to publicize. :wink:


#14

If you have paint or photoshop (or some equivalent) you can paste into there and edit it out.
For windows, you can avoid opening any photo editing by using the Snipper Tool.
On macOS, you can use “lightshot screen shot” which allows you to edit the screenshot before it saves to the clipboard.


#16

It was the autofill. I didn’t turn it on so I’m guessing the system default is to have it on.

UPDATE:

Well, not quite. It’s started happening again.

It looks like what I did just cleared the existing auto-fill entries.

Can you tell me where the setting to totally ‘turn off’ auto-fill is?

Thanks.

P.S. – This is in Brave Dev. Doesn’t “Legacy (Muon)” refer to the standard release that’s no longer being updated? . . . v. 0.55.2 Chromium: 70.0.3528.4 (Official Build) dev (64-bit) on Mac (OS 13.9.5)