How to change default :mailto link


#1

Once I logged into my gmail account in Brave every :mailto link has defaulted to gmail. How do I change this?


#2

Hi @CurlyGirlMom,

Is this on desktop or mobile (Android or iOS)?
cc @sriram or @LaurenWags for assistance.

:slight_smile:


#3

Also looping in @Mattches our new User Support Engineer for assistance :smiley:

Best,
Lauren


#4

desktop version
Brave 0.22.810
Mac OS 10.13.5


#5

@CurlyGirlMom In about:preferences#security Under saved site permissions, click the X beside mail.google. etc. You can remove it from both location and notifications. Did that fix it?


#6

Thanks for the suggestion. I looked through that list last night.
The only spot google shows up in the saved site permissions list is under ‘location access’ and that one is set to ‘always deny.’ The word mail doesn’t show up at all.


#7

Hello @CurlyGirlMom,

Would it be possible for you to provide a screen shot of your saved site permissions in the Security tab? Also, which mail services have you tried to use that end up defaulting to gmail instead of the intended mail client?

Thank you for reporting! :slight_smile:


#8

Could you check if you have an entry like this in Settings->Security
image

If you have then clear it so that it doesn’t associate the :mailto to Gmail as the protocol is now tied to Gmail.


#9

Sorry, I don’t see anything like this. I went to Preferences; then to Security. Nothing in there says ‘Protocol registration.’


#10

That’s the majority of it. There’s more ‘autoplay media’ sites but nothing else.

I’d like to be able to tell it to use my hotmail or my icloud email address. My last choice would be the gmail account it is defaulting to.


#11

@CurlyGirlMom I have tested and found the solution.

Give this a try, goto your Application Support Folder.
~/Library/Application Support

Once you are in here select the Brave folder.

Select the file called UserPrefs - open it up in text editor of choice or default.

Once you’re in the text editor things might look messy, use Command F enter in mail. You should now see the mail words highlighted.

You need to change True to false on the one the in my line with the highlighted yellow mail.

*As you may notice I already did that in this example.

After you change the word to False - save the file.

Reopen Brave and test out a Maito of your choice, should now ask you to use an external program.

Or if you choose like I did to use another mail service like Protonmail, just change the URL.

https://mail.protonmail.com/secure/start?action=compose&to=%s

**You may need to search for the URL from your hosting provider ie Outlook.com, gmail, yahoo etc…


#12

Brillant! Thank you! That did the trick.


#13

@CurlyGirlMom Glad I could help you out! Can you please mark my post as the solution?


#14

Thanks! I had the same problem. Somehow, Gmail had “stolen” the preferences to open mailto links, and there was no UI in Brave to set that back to the default.


#15

some same related issue i got here
When I click a mailto link does not show ProtonMail as an option for me. I’m on Firefox. **Is there a way I can add it?**Any way to set ProtonMail as default for mailTo links?


https://discord.software/ https://adobereader.onl/ https://itunes.red/


#16

Currently without a PAID for Account with Protonmail there is no way to use mailto:


#17

friend, appreciate your solving this problem.


#18

brave, if you’re listening, you need to put this at the top.