How do I stay logged in?

If Brave is closed down for a while and then reopened I have to log back into all my websites. How do I stay logged in?

Description of the issue:
Can’t stay logged in after shutting Brave down.

I’m on a Linux Mint laptop and am using Version 1.58.127 Chromium: 117.0.5938.88 (Official Build) (64-bit)

Here’s a screenshot of my shield settings:
Imgur

Thanks for any pointers.

@thusband can you check at brave://settings/clearBrowserData and see if you have anything checked off for On Exit?

image

Ah yes, everything has been checked. I guess that explains it. What would be the minimum I’d need to keep sites open?

Thanks for the help!

edit: I’ve unchecked all the boxes, logged into a few sites and then closed Brave and my Linux Mint laptop. When I open everything back up I still have to log into the sites again. So really nothing has changed.

@thusband I just want to confirm something. When you looked at the boxes, did you make sure to change tabs? I only ask because I had someone in the past who looked only at the Basic tab which is what opens by default, they didn’t notice they had to click on On Exit to switch to that and then check. So I tend to play it “safe” by asking for confirmation these days.

Yes, thanks, I used the exit tab and unchecked everything. I logged into one site and then closed Brave. When I opened it again I had to log back in.

The first four items in the advanced tab are checked, everything else in all other tabs is unchecked.

@thusband ok, so the next thing that would be checking is your extensions. The simplest way to test this would be to create a new browser profile for testing.

Go to Hamburger Menu imageAdd new profile → Name it whatever you want and hit Done

Once this is created, don’t install any extensions and don’t change any settings on this new profile. We’re leaving it default for testing purposes. Just go to the websites and login. Then see if it logs you out there when you exit. If it doesn’t, then it confirms it’s either settings or extensions, but most likely an extension.

The next step would be to either remove all extensions from your main profile to see if the issue goes away, at which point you’d add extensions until you find the culprit. Or you can just add extensions to your test profile and see if it happens there. Either way, should help confirm if it’s extensions. Then from there would have to narrow down which one.

OK, thanks again. That will be a little time consuming since all my passwords are in Bitwarden on the other profile or in Chrome. Maybe I’ll try just shutting all extensions off (not uninstalling) and one by one turn them back on to see if there’s a problem. There’re only a half dozen.

Creating the new profile and testing looks like it might an extension.

edit: Well even turning off all extensions the site still requires logging back in after shutting down. I’m spending too much time sorting this out so I’m going to put the whole thing on hold for a while and go back to Chrome. I’ll keep Brave but use it when logins aren’t needed.

Thanks for the help though.

1 Like

@thusband might have also been good to try to install them one by one on the second profile and see when it changes. But for it to only occur on one profile, it definitely is a sign that there’s a setting or extension causing your issue.

I’ll tag @Mattches to see if he might have any other guesses, but I’m pretty sure that’s just what we’re down to having to do. Sorry I couldn’t help get an easier/quicker answer.

1 Like

I’m still inclined to think it is an extension issue — especially if you tested this in a new profile and were not able to reproduce. Going to see if we have any open issues for this or if it’s being discussed internally or not.

Thanks all. I really appreciate your efforts.

Maybe it’s resolved? I turned off, “Clear cookies and site data when you close all windows” and sites seem to stay open now. It hasn’t been overnight yet but it’s progress.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.