How do I reset "Save Password" prompts or manually save passwords?

bug
windows

#1

Hello. I’m running into issues with saving the correct password for a site. The timeline is as follows:

–logged into site with old password
–Would you like to save this password? prompt appears
–I change my password on the site to the new password
–I log out, then log back into the site with the new password
–I click “Yes” on the original save password prompt
–The old password is saved to the browser’s list
–I remove the saved password via About:Passwords by clicking the “X” next to the old password
–Would you like to save this password? prompt does not appear again for the original username nor for new username/password combinations on the site

How do I get the browser to save my password for the site in question? Is there a way to manually input a password to Brave’s list or a way to get Brave to ask me to save the password again?

Windows 7 Home Premium 64bit

Brave: 0.18.23
rev: 36ae2ec06efed0057ae16351108bf4d4c10a7ab4
Muon: 4.3.10
libchromiumcontent: 60.0.3112.90
V8: 6.0.286.52
Node.js: 7.9.0
Update Channel: dev
OS Platform: Microsoft Windows
OS Release: 6.1.7601
OS Architecture: x64


#2

Hi @secv

Can you try closing the tab that the site is in and opening the site in a new tab? If that doesn’t work, could you make sure you don’t have the site open in any tabs and then close/relaunch Brave? I noticed that if I tried to reuse the same tab I wasn’t prompted for a new username/password save, but if I used a new tab I was prompted.

Thanks,
Lauren


#3

Thank you for replying. Some interesting things have happened. For reference I am trying to log in at this page: https://www.tumblr.com/login

I am curious if the format of the login fields are causing an issue. In this case, the username is inputted first, then a new set of username/password fields are presented to complete the log in.

When I first posted this issue, I did not get any “save password” prompt. I tried terminating the browser by clicking the exit button (top right) and retrying after opening the browser again with no results. However, after I turned off my computer and turned it back on in the morning I get the “save password” prompt right away. There is still an issue, however.

I saved the username/password combo for account #1 easily. I then logged out to try the same with account #2. The first username field is already filled with username #1. I enter the username for account #2 and click “log in.” The next set of username/password fields contain username #2, but password #1. Brave then asks to save password #1 as the correct password. Entering the correct password (#2) then logging in does not cause Brave to save the correct password.

I tried logging in via a new session, a new tab, and after closing/reopening the browser and got the same results. Deleting the username/password combo for account #1 causes the original behavior again where no prompt is given. But this time, the username for account #1 still appears as a drop-down selection.

I will restart my computer and try to video the issue.


#4

One other update, I did not see this behavior on the https://www.reddit.com/

When trying to save passwords at https://twitter.com/?lang=en the login popup produced by the “Log In” saved the username but no prompt was produced. Using the “Log in in to your account” box in the center of the page did work. (Updated within the update: I was served two different twitter home pages under the same address within minutes. The second home page does not have the log in button or the purple styling of the first.)


#5

Hi @secv

Do you see the same behavior if you try to use different session tabs? Meaning, if you right click on the + sign in the tab bar and select ‘New Session Tab’ or you can also add a session tab from File > New Session Tab.

Thanks,
Lauren


#6

Yes, I see the same behavior. Signing in via different sessions on both accounts did not trigger the prompt. I also tried this step after restarting both the browser and the computer. The username #1 prompt still exists as well despite the password having been deleted from the list and persists between restarts/session tabs.


#7

I’m having a similar problem. I had simply changed my password, but Brave remembers only the obsolete password. Brave doesn’t prompt me to save updated password. I then deleted the password from the list of Brave passwords, exited Brave (all sessions) and then tried to access the site with the new password. Although I can log in to the website by manually entering the new password, Brave still doesn’t prompt me to update or save the password.