How do I have a clear history?

then let me ask @Mattches from the team to help you

@Mattches he asking to make brave auto clear history on exit but when he go to brave://settings/clearBrowserData the save button is disabled

i asked him to clear it manually (using advanced tab) and also to disable all extension but the save button still does not want to be activated

Edit: @Mattches he confirm that he has latest vversion with windows 10 pro

@Samue1 could you go to brave://settings/help and make sure that brave version is
Version 1.47.171

and what is your windows version ?

Thanks, for the help!

1 Like

I have fully updated brave, I have windows 10 pro.

1 Like

you welcome and hope your issue get fixed soon :slight_smile:

does not select my comment as solution or the team maybe by mistake think that the issue been solved so remove it :slight_smile:

This is a known issue that was just recently resolved:

The fix is in Beta now and should be landing in Brave stable in the next browser update.


Thanks for the reply, but the ‘save button’ seems to be of grey colour meaning I cannot complete this solution.

@Samue1 he meant that it’s an issue and they fixed it for the beta version so when you get update for version 1.48.122 or above it will be solved for your case

1 Like

:point_up: Yes, this is exactly correct. Thank you for clarifying @justsomeone1

1 Like

@Mattches thanks for you for help

Thanks! I’m glad to hear that.

1 Like

you welcome @Samue1 :slight_smile:

Hello @Samue1

currently the latest version is
Version 1.48.158 Chromium: 110.0.5481.77 (Official Build) (64-bit)

which should solve your issue

Thanks, but it says my browser is up to date, how do I fix that?

you welcome when you go to brave://settings/help what the version there?

The new one, I re-installed it. But now I fixed my favorite browser, so I may not be using it.

sorry but i do not understand what you mean

My old browser is working.

still not sure what you mean

but does opening brave and clear the cache on exit work or not?

Yes, it does work. Thanks!