How do I enable Box Tools in Brave on mac OS?

Description of the issue: When I download and instal Box Tools, Brave does not let me open files in Box (i.e., it does not recognize that Box Tools has been installed).

Steps to Reproduce (add as many as necessary): 1. 2. 3. 1, Open Box 2. Click on a file, 3. Select Open, 4. Under Microsoft Word (or other file type) there is a link to “Install Box Tools”. 5. Download and install. 6. Repeat. (Brave never recognizes that Box Tools is installed).

Actual Result (gifs and screenshots are welcome!): When Box is opened in Brave, it does not recognize that Box Tools had been installed.

Expected result: Open the selected file using the selected app (e.g., Microsoft Word)

Reproduces how often: Every time.

Operating System and Brave Version(See the About Brave page in the main menu): macOS Catalina. Brave: Version 1.13.86 Chromium: 85.0.4183.102 (Official Build) (64-bit)

Additional Information: Works find on Google Chrome.


Trying to test this on my end but I’m actually running into issues installing Box itself. Will let you know when I work it out/have more information for you.

Additionally, can you share the exact link for the Box download you used to ensure we are using the same product?


When clicking on the boxtools link, just save to a folder, then open?

I’ve had this exact same problem. I don’t think that it’s a problem on Box’s end, because I tried to repeat the process on Google Chrome and Box worked just fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.