How Do I Disable Prefetching Of Links

After noticing some entries in my pihole that I wasn’t clicking I decided to do a test to see if brave was prefetching links I never clicked on, here is the proof in from my pihole logs
brave-why-are-you-visiting-this
How do I disable this feature?

Please do not suggest I go to:
Settings > Privacy > Cookies > Preload toggle
because that is no longer there.

1 Like

Not sure actually, good question. But I don’t know what that entry is, ‘brave-why-are-you-visiting-this-link.com’ does not seem to exist – no domain record and no DNS – so maybe this specific example (assuming that’s the literal entry and not something redacted) wasn’t due to a prefetch?

I created a blank HTML page with a link to brave-why-are-you-visiting-this-link.com to test if brave was visiting links on a page that I didn’t click. So brave “read” the link in the HTML page and tried to prefetch it in the backround which showed up in my pihole.

I work in a web development related field and don’t really want brave deciding on it’s own to visit links on a page that I’m not clicking. I understand it’s trying to be “helpful” by prefetching content, but it’s not expected behavior, and it’s the exact opposite of helpful.

Looks like the option was removed here: https://github.com/brave/brave-browser/issues/16957

It would be hard to believe that the option would be intentionally removed, but not the behavior.

Based on this, it seems that the intent is for the behavior to likewise be disabled: https://github.com/brave/brave-core/commit/3ebe2a9fec76928264bd7ff8f7f0500c2286a1e9

What version of Brave are you running? If it’s an old one, maybe it’s from before this behavior change? And if it’s a new one, then maybe you’ve come across a bug.


Version 1.45.113 Chromium: 107.0.5304.62 (Official Build) (x86_64)

Removing the front-end but not removing the back-end? I would not be surprised if it was the case here.
When they rewrote their adblocking engine, it took them a year or so to notice it was not enabled.

I think you meant ‘not surprised?’

In any case, that’s why I said intentionally.

@A_Guy_In_A_Place you should probably file a bug, although maybe get it up to 1.45.116 first and confirm the issue is still there.

@Mattches FYI :point_up:t5:.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.