How do I disable auto-update?

I got a dialog asking if I want to auto-update Brave and very unfortunately dismissed it without unchecking the option. I see no option in the preferences. I use a lot of private tabs (despite the poor Google implementation) and I don’t want to auto-restart the browser. Ever.

1 Like

@Ball,
Can I ask why you want to disable auto-update? This is generally a bad idea for security reasons and is strongly advised against.

  1. Restarting the browser kills all my private tabs. Unfortunately Brave does not support multi-account containers. Instead it just behave like Chromium. Unfortunately every single Chrome extension with this ability is ad/malware.

  2. I travel a lot and for this reason I absolutely do NOT use Brave when on the road. Why? It will initiate a download of a large file without prompting. This is also why I block Apple and other chatty apps that treat me like a product and not a user.

  3. Because THAT’S WHAT I WANT and I shouldn’t have to explain why.

You didn’t mention what environment you’re running on
EDIT: NEVER MIND … I missed the MacOS TAG : )

it’s macos
Screenshot from 2020-10-14 00-45-53

@Ball
You can use the --disable-auto-update runtime flag if you’re that interested stopping them.

This looks like a better method:

https://www.techrepublic.com/forums/discussions/disable-brave-browser-auto-update-on-a-mac/

Both methods are an equal security risk so yes, fell free to use either.