How can I make Brave display pages in English?

Hi, I’m currently in Sweden and Brave is starting to display most pages in Swedish instead of English on my Mac and iPhone. Is there a way to change that?

@CooperOnTheRun ,

Search criteria:

web pages in English while in foreign country

Found:

https://www.w3.org/International/questions/qa-lang-priorities

@CooperOnTheRun have you tried here: brave://settings/languages ? :slight_smile: