How can I disable Rich Entity Suggestions in Browser?

I am attempting to disable Rich Entity Suggestions on Brave Browser, however I cannot find a way to do so.

My version is for the Brave Desktop Browser on Windows 10.

1 Like

Hello there @Zakku please try the following, go to brave://settings/appearance > Show autocomplete suggestions in address bar > unmark suggested sites

Let me know if that works.

That didn’t work unfortunately. I am trying to disable the image next to search suggestions, for example if you search Steve Jobs, you see the image next to his suggestion. The images are distracting for me.

1 Like

Hi again @Zakku let me inform you that such option is not available for Brave at this time. One thing you could try to avoid seeing those suggestions is enabling Block scripts on shields.

Also, if you’d like you can open a feature request topic regarding adding an option to be able to remove Rich entity suggestions. Please see

If you have other concerns, let me know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.