How can I deactivate URL spell check in Brave browser

Hello, I am using 2 websites that have almost the same URL - one has a single letter more than the other while the rest of the spelling is the same. Although I use both sites regularly, every day when I want to visit the 2nd site (which has one more letter as described above), I am asked if I didn’t actually mean the other URL.

How can I disable or change URL spell check settings? It’s very annoying that this popup comes up every day asking if I didn’t mean the other URL.

Unfortunately, searching for URL spell check in the Brave Browser didn’t return any suitable results.

Thank you in advance for any efforts to resolve the issue.


Brave Browser on desktop / Windows 10
Brave Version: Version 1.47.186 Chromium: 109.0.5414.119

Search for ‘safe browsing’ in settings and turn it off, it might work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.