History Channel Article not displaying

When trying to read on the This Day in History website, I clicked the read more . . .link. Brave doesn’t display the rest of the article. I don’t have this problem with the Chrome or Firefox browsers.
Description of the issue:
How can this issue be reproduced?

1.Here’s the link: https://mail.yahoo.com/d/folders/1/messages/AH5I1Gony5aiZmbPPQ7YyGUiJfY
2.Here’s the resulting landing page: https://www.history.com/this-day-in-history/first-salem-witch-hanging?cmpid=email-hist-tdih-2024-0610-06102024&om_rid=5c174346d28fe286561cbc72d22fcb16f6f974b8b5243a2e57d60c0449b6fbcb

Expected result:

Brave Version( check About Brave):

Additional Information:

I’m able to see the link in which you land on (second one listed above) in Brave. Where exactly are you clicking the first link that leads you to that? Is it in an email?

The link is a Yahoo mail link. You say you can see the link, but did you click it? When I click, it brings me to the article. However, there is no text body on this page. Chrome and Firefox display the text body. So, something is wrong. Also, on Biblegateway.com, some pages don’t display properly. Here’s an example.
The bottom part of the page seems to cover up most of the page. Again, this doesn’t happen on either Chrome or Firefox.

There’s something wrong. I cleared my cache, cookies, and browsed data in Brave, but that didn’t do anything.

Yes, I clicked both links and both open without issue:

Can you please tell me what OS and Brave version you’re using?

Additionally, can you please try opening a guest profile (Menu --> More tools --> Open Guest profile) and test and see if the links display properly for you there?

Brave Browser version:
Version 1.66.118 Chromium: 125.0.6422.147 (Official Build) (64-bit)

Windows 10 version 22H2, OS Build 19045.4412
Windows Feature Experience Pack 1000.19056.1000.0

I created a Guest profile. The two links work with that. Thanks.

If the sites worked on the guest profile, but not after clearing cache/data then the issue may be an extension that you have installed on your profile.

Either that or you may need to have deleted data from a longer time range. You can also try clearing site data for those sites specifically by clicking on the “tune” icon in the address bar, then Site settings --> Clear data:


I went to Settings - Reset Settings - Restore settings to their original defaults.

That did the trick. Thanks.