Highlighting words and selecting "Search Google For" seems broken

Description of the issue:

When highlighting words on web pages, right clicking and selecting “search google for…”, the page will seemingly load indefinitely.

**Steps to Reproduce (add as many as necessary)

  1. Go to any web page with words on it.
  2. Highlight any word. Right Click.
  3. Select ‘Search Google’ in the right clicked menu.
  4. A page should load from google search of the word you highlighted.

Actual Result (gifs and screenshots are welcome!):
I get just a white screen that won’t load.

Expected result:

A google search page of the word or words you highlighted should show up.

Reproduces how often:

Happens almost 100% I have messed around with my extensions but here is what happens: I disable an extension and reload. I then do a highlighted search, it works. I reload the page again and search a second time, the infinite loading returns.

Operating System and Brave Version(See the About Brave page in the main menu):


Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)

1 Like

@Mr_Internet

In a Brave Browser > New Window, go to:

  • brave://settings/content/siteDetails?site=https%3A%2F%2Fwww.google.com

and set the following:

  • JavaScript: Allow
  • Images: Allow
  • Sound: Automatic

As a test . . .

Next, go to: brave://settings/searchEngines

  • Enable: Space or Tab

Among the Search engines listed, you will likely find Google, but, is it also your ‘Default’ search engine?

I use StartPage search engine:

Screen Shot 2022-06-13 at 9.51.16 PM

Your settings window should show something similar for Google - the double-entry (one, is ‘Default’).

I highlighted ‘infinite loading’ from your Original Post (“OP”) above, and then moved the mouse arrow in order to highlight a selection within the pop-up menu:

  • Search StartPage for “infinite loading”

I repeated those steps for, and tested both of, the following actions:

  • Click with the mouse button
  • Click the SPACE key of my computer keyboard

BOTH responses were good: proper display of StartPage Search Engine results.

BUT, I am wondering what are the responses that you get?

Note: Brave Browser is not my default Internet browser; but you might test that condition.

I’ve checked everything you mention… my settings are all set as you want them, and google is my default search engine. I tried highlighting something and pressing space to test that, all that happens is I’m scrolled to the bottom of the page.

@Mr_Internet

Thank you for running thru all that. I thought, there might be a chance for the SPACE key in lieu of the mouse click - on a fluke; but at least a possibility has been tested.

Your issue appears to be a real BUG (actually, something overlooked?), possibly for @Mattches (Brave Support) to consider.

@Mr_Internet,
I would try clearing your cache/browsing data and then test again.

  1. Visit Google.com
  2. Click the “lock” icon in the address bar
  3. Click Site settings
  4. Click Clear data
  5. Close the page

Then try performing this action again.

I have completed your steps and the issue still persists.

Hi

@Mr_Internet

If you can see the blank page loading try this:

Right-click on that page, click on inspect, go to network then choose throttle if offline as in image below.

When a page is in this loading loop, right clicking will not work. I hit F12 though, was able to get to that menu. No Throttling is already selected. No change. Might be of interest, there is no activity showing in that menu unless I press the X and refresh the page, in which it will then load.

@Mr_Internet,
Can you please try a couple more tests for me?

  1. Try testing this behavior in a Private browsing window
  2. Try creating a temp. test profile and see if the behavior is the same when using the new profile.

Hi. Both in a private window and a test profile, this highlight search works correctly again.

I assume this means an extension is causing an issue. I can try to trouble shoot again but as I said earlier, it seemed the issue would reoccur after a second refresh from disabling multiple extensions at a time.

@Mr_Internet,
In your main profile, try disabling all extensions and see if the function works. If it does (consistently), try re-enabling them one at a time and re-testing until you find the offending extension.

Okay. I am in the middle of testing and I am confused. So far, 8 extensions seem to intermittently cause the issue. It doesn’t seem to be just one. I’ll continue testing and get back to this thread, but how can multiple extensions be the cause?

EDIT:

I am stumped. Hopefully someone can further assist. Here are all the extensions that intermittently cause the highlight search to break.

AHA Music
gmail classic
reddit enhancment suite
AudioRead
Social Fixer for Facebook
Natural Reader Text to Speech
google images restored
wikiwand

The following extensions broke search when reenabled alone but after browser restarts, highlight search might not work on first go, but after a failed first try, it seems to work until a browser restart.
tampermonkey
Honey
Sponserblock
channelblocker

@Mr_Internet,
Given the inconsistency I’m not sure how much that narrowed it down but I do appreciate you testing all that. I suspect that this still does have something to do with your specific profile — I have Honey installed and just installed tamper monkey as well and I cannot reproduce this issue on my end.

I’ll have to do a little more digging here, appreciate your patience.

@Mr_Internet

Maybe . . .

An issue that might be summed up by one of the topic titles used:

You might try the fix, there, that applies to Windows OS users.

That may not completely resolve your issue, but it might narrow down the particular extensions that are troublesome.

I appreciate you looking into it, hopefully you can figure out what’s up.

I’m sorry, but where exactly do I place the string of words in the shortcut menu? I tried adding it to the end of ‘target’ and ‘start in’ and Windows gave me an error. Sorry I’m not great when things act up like this.

@Mr_Internet

Mind you, this is a test, and the following is an example.

In the following example, there are TWO PARTS.

The FIRST part, is the executable path including the leading and trailing double-quote marks:

  • "C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe"

The SECOND part, is the switch (aka flag) of interest:

  • --enable-features=NavigationThreadingOptimizations

When COMBINED, there must be 1 SPACE character between the FIRST and SECOND parts:

  • "C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe" --enable-features=NavigationThreadingOptimizations

In actual viewing of what you see on your Windows OS machine, you may already have the FIRST part followed by one or more switches:

  • "C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe" [followed by one or more switches]

You are going to ADD the particular switch:

  • --enable-features=NavigationThreadingOptimizations

to the existing tail end of what you see on your Windows OS machine, separating the switch by 1 SPACE character, from the existing tail end.

What I finally did, in order to make use of the proposed fix, switch:

  • --enable-features=NavigationThreadingOptimizations

In a Brave Browser > New Window, I sent the browser to: brave://version

I copied the entire Command Line string, to a text editor window, in which I could then edit the string.

brave_version_find_Command_Line_string

The leading part of the Command Line string:

  • /Applications/Brave Browser.app/Contents/MacOS/Brave Browser

I replaced with the following string:

  • open -a "Brave Browser.app" -n --args

then I added a single SPACE character, followed by all of the known switches (there are several) plus any flag switches.

IF there are flag switches, then they will begin with switch:

  • --flag-switches-begin

and end with switch:

  • --flag-switches-end

So, IF there are flag switches, then the proposed fix, switch:

  • --enable-features=NavigationThreadingOptimizations

I located BEFORE switch:

  • --flag-switches-begin

IF there are NO flag switches, then I located the proposed fix, switch at the tail end of all the switches.

And I made sure to also include the necessary single SPACE characters, because there needs to be a single SPACE character that separates all the switches.

I am using 2 flag switches.

So, the altered Command Line string that I use, became:

  • open -a "Brave Browser.app" -n --args --disable-client-side-phishing-detection [FOLLOWED BY MANY SWITCHES, AND THEN THE PROPOSED FIX, SWITCH:] --enable-features=NavigationThreadingOptimizations --flag-switches-begin [FLAG SWITCHES] --flag-switches-end

That is the Command Line string that I entered into the Mac’s Terminal.app window, in order to start up Brave Browser.

Okay, thank you for that. Still a no go.

However, if I change the default search engine, say to duck duck go, highlight search works with all extensions enabled. Obviously I’d like to use Google.

@Mr_Internet

“a no go” means? Need more detail than that. Unable to determine if you could not enter the particular switch(?) -or- Brave Browser did not perform as you where hoping?

The highlight search is still broken even after adding * --enable-features=NavigationThreadingOptimizations.