High CPU usage when viewing code snippets

Description of the issue: High CPU usage when viewing inline code in Brave. For example, on these two LLVM documentation pages, Brave pushes my CPU usage to 100%:

https://llvm.org/doxygen/IR_2Instruction_8h_source.html
https://llvm.org/doxygen/classllvm_1_1Instruction.html

My CPU is also very high when viewing Piazza posts with inline code snippets (I cannot post the Piazza post here since it is private).

Screen Shot 2020-09-12 at 4.39.22 PM

Top two entries in the CPU tab are Brave’s Renderer processes:

How can this issue be reproduced?

  1. Visit https://llvm.org/doxygen/classllvm_1_1Instruction.html or https://llvm.org/doxygen/IR_2Instruction_8h_source.html
  2. Wait a few minutes and watch CPU usage increase to >80%

Expected result:

Be able to visit the websites with low/normal CPU usage.

Brave Version( check About Brave):
Version 1.15.46 Chromium: 85.0.4183.102 (Official Build) beta (64-bit)
macOS 10.15.6
MacBook Pro (Retina, 13-inch, Early 2015)

Additional Information:
Although I doubt this has an impact, I also want to mention that I am using custom fonts:

1 Like

I couldn’t replicate in Windows (Brave Beta)

I would try testing in a new/clean profile

I just opened both tabs again and my CPU usage is spiking. Maybe it is macOS specific?

@jc713,
I’m also testing this on macOS and am unable to reproduce. May be an extension that you have installed? Can you try creating a new browser profile (Menu --> Create new profile), visiting one of those sites and seeing if you get the same CPU spikes?

So I just created a new profile and visited both sites. In task manager, only https://llvm.org/doxygen/classllvm_1_1Instruction.html is causing a spike in CPU on the new profile.

Have you tried installing/using the custom fonts I listed above? Could this potentially be the culprit?

It could be the fonts, and I"ll download/test, but I think it’s likely a simpler solution.
Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Sadly disabling hardware acceleration did not fix the issue, the tab is still topping the charts with 95%+ CPU usage.

Issue is still occurring on the latest beta update: Version 1.15.51 Chromium: 85.0.4183.102 (Official Build) beta (64-bit)