High CPU usage when Brave is open (no matter in which page)

I feel like this same thing is happening with my Macbook Pro. The fan was going crazy while watching The Netflix Slam in Brave & only relaxed after closing out the tab. I didn’t know to check for CPU.

Hey, this workaround stopped the System process from always running too many interrupts!

  • Windows Settings
  • Search for Graphics Settings
  • Click “Browse” button
  • Find Brave Browser under C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe
  • Then tell it to use the “Power Savings” Intel (R) UHD Graphics

As opposed to the High Performance Nvidia GeForce GTX 1650 TI (in my Dell laptop).

100% reproducible with Brave open on an empty tab.

System process uses unexpected amount of CPU, where Process Explorer shows the interrupts are getting hit way too often.

2 Likes

High CPU usage with computer fan running whenever I try to stream videos in Brave. Specifically, YT live streams of tennis matches or streaming through WatchParty.

https://old.reddit.com/r/brave_browser/comments/1c7ejvm/draining_battery/

Not saying its the same issue or extension, but disable all extensions. Run Brave “clean”, Shields = Up also. Ensure HW acceleration is enabled. Should help with Battery use.

Screen Shot 2024-04-21 at 1.00.00 AM

Whenever I try to watch…

  • live streams of tennis matches on YouTube
  • use WatchParty with a friend
  • T2 (on Amazon, Plex, etc.)
  • live stream of the Netflix Slam
  • watch PlutoTv on desktop browser

I see the Brave CPU jump into the high 30s. When it gets even higher, the image can lag and the fan turns on which is annoying, distracting, & loud.

  1. I don’t use extensions. They only cause more problems in the long run.
  2. Shields are always enabled.
  3. Graphics Acceleration, Memory Saver, & Energy Saver are always enabled.
  4. I’ve seen conflicting advice: turn off hardware acceleration. No, turn on Hardware acceleration. So, I disregard & just keep whatever was there.

How do we fix this given the plethora of now closed threads on this subject dating back to 2020?

“I’ve seen conflicting advice: turn off hardware acceleration. No, turn on Hardware acceleration”

It is not conflicting advice. After the initial work around was offered, a 2nd alternate work around was also offered.

  1. Turning off any hardware acceleration is indeed one way to avoid the particular problem of this issue as indicated first by NickW in his two messages on Feb 15, and as confirmed by others (e.g. moroack Feb 22). I also found this worked. Notice that this work around only affects Brave by turning off the hardware acceleration setting just for Brave.

  2. Later newto (Mar 6) and more clearly MCP (Apr 4) found a more specific work around where one could leave hardware acceleration on if one forces the Windows system settings to make a different choice about the graphics card (i.e. don’t use the default choice). MCP gave clear instructions. On his system he made it “use the “Power Savings” Intel (R) UHD Graphics” rather than the default of “the High Performance Nvidia GeForce GTX 1650 TI”. Notice that this solution does allow hardware acceleration for Brave, but it affects the whole system (not Brave only) because it changes a Windows setting and makes the Windows system in general avoid the Nvidia card for acceleration.

I found that either of these work arounds was successful for avoiding the problem of this issue. I have a Dell XPS 17 9700 running Windows 10 Pro that was also defaulting to using a Nvidia GeForce (RTX 2060) card.)

NOTE: Some might prefer to negatively impact Brave only rather than change the Windows system to avoid the Nvidia card in for acceleration generally.

But working around the problem is not the same as having the problem fixed. Brave needs to resolve the actual incompatibility (whatever it is) with using certain cards for hardware acceleration.

So the problem isn’t hardware acceleration in general, but more specifically it is a problem using a particular hardware acceleration (e.g. some problem using the Nvidia GeForce cards to hardware accelerate Brave).