Hide button on /r/Dashboard of Reddit Enhancement Suite extension doesn't work after Version 0.57.6 update


#1

Description of the issue:

Updated to Version 0.57.6 Chromium: 71.0.3578.31 (Official Build) beta (64-bit). Can’t hide Reddit posts on /r/Dashboard of RES extension

Steps to Reproduce (add as many as necessary):

  1. Install RES and add some subs to its Dashboard,
  2. Open RES Dashboard
  3. Click on the Hide button on any comment under any sub.
  4. These two errors come up (always doubled)

VM495 :1 Uncaught ReferenceError: change_state is not defined at HTMLAnchorElement.onclick (VM475 :1)

onclick @ VM495 :1
(index):1

Uncaught ReferenceError: click_thing is not defined
at HTMLDivElement.onclick (VM475 :1)
onclick @ (index):1

Actual Result (gifs and screenshots are welcome!):

Reproduces how often:
100%

Brave Version(about:brave):
Version 0.57.6 Chromium: 71.0.3578.31 (Official Build) beta (64-bit)

Reproducible on current live release (yes/no):
Not tested.

Additional Information:
Comments can be hidden while in their subreddits. For example, I can hide any post while on www.reddit.com/r/brave_browser, but I cannot hide the same posts while on /r/Dashboard/r/brave_browser

Only RES extension is enabled.


#2

@smartfon,
Apologies but can you reconfirm your version number? I’m assuming its a typo and you meant 56.7, correct? There aren’t any current builds with that version number.

For now I’ll assume that’s the case.
As for your issue, I’m unable to replicate it on my end using Beta. It did take a second, which I thought was weird, but ultimately it hid as intended:

What do you have your Shields set to for Reddit?


#3

It updated few hours ago. It did so after I clicked on a black up arrow button which replaced the menu icon on the top-right corner.

The problem is still happening on my end. When you hide the post in Dashboard, could you open the dedicated subreddit on its own page and see if that comment is also hidden from there?

I have just reinstalled RES.


#4

What do you mean “There aren’t any current builds with that version number.” is me and this other guy using a fake version of Brave? I have the same build number :

:worried:


#5

Bump @Mattches . :blush:


#6

Hey, sorry guys, my bad for leaving you high and dry.
I just got in front of my laptop, let me set up and I’ll take another look at this. Appreciate your patience.


#7

Still not sure what’s going on. Hiding seems to work for me just fine and the hidden thread does get removed from the main subreddit page:

What do your Shields look like (on reddit)?


#8

(Solved)

The Brave Shields are off. Tested with a fresh profile, same problem. Exported RES to Chrome and it worked fine.

The Hiding worked when I removed RES and reinstalled it with the default settings. I suppose a recent change in Brave became incompatible with one of the features that I configured in RES.

After a lengthy visual comparison between the default and my configured RES, it became evident that the issue was caused by the fact that I had the fixHideLinks switch disabled. This is something I had done years ago, but only now it caused a problem.

The browser Console error can be disregarded because it appears there regardless whether the hiding is successful or not. You may mark this as “Solved”. Thanks for your time.


#9

@smartfon, excellent sleuthing. I respect your diligence digging into the issue.

Glad that it’s up and running. If you have any more questions or concerns please don’t hesitate to reach out.


#10