Help Needed: SCons Error While Building Brave/Omaha on Windows 11

I’ve been trying to build the Brave/Omaha project for over two weeks, but I’ve encountered a persistent error related to SCons, which I haven’t been able to resolve.

System Configuration:

  • Operating System: Windows 11 running in VirtualBox using an .ova file
  • Allocated RAM: 4GB
  • Memory Allocated: 120GB
  • Host CPU: AMD Ryzen 7 5800H
  • Host GPU: Nvidia GTX 1650

What I’ve Done:

  1. Followed the guide provided in the Brave/Omaha repository for setting up the build environment.

  2. Downloaded and set up the required tools in the specified directories as per the documentation.

  3. Updated the hammer.bat file to include the paths for any tools that were not in the specified directories.

Despite these steps, I am still encountering an error related to SCons during the build process. Below is a screenshot of the error message:

Steps Taken to Troubleshoot:

  • Verified the installation paths and configurations in hammer.bat.
  • Ensured all dependencies are correctly installed and accessible.
  • Cross-referenced the setup guide multiple times to ensure no steps were missed.

I would greatly appreciate any guidance or suggestions from the community to help resolve this issue. Has anyone faced a similar problem, or can someone point out what I might be missing? Any advice on troubleshooting SCons errors specifically in the context of building Omaha would be extremely helpful.

Thank you in advance for your support!

@MasterK0927 it’s currently the weekend and Support generally isn’t active on weekends or American holidays. I would try walking through things with you but I’m not knowledgeable at all.

What I did do is share the screenshot to ChatGPT for the heck of it. Not sure if any help or accurate, but at least it’s something for the moment. Answer from ChatGPT is below:

Based on the provided image, the primary issue seems to be with the Visual Studio C/C++ compilers not being detected correctly. Here are some steps to troubleshoot and resolve this issue:

  1. Install Visual Studio: Ensure you have the correct version of Visual Studio installed with the necessary C++ build tools.
  2. Environment Variables: Verify that the environment variables for Visual Studio are correctly set. You might need to run vcvarsall.bat to set them up.
  3. SCons Configuration: Double-check the SCons configuration to ensure it points to the correct paths for the Visual Studio tools.

If these steps do not resolve the issue, you might need to provide more specific error details or seek further assistance on the Brave community forums.

For shits and giggles tested Gemini as well. It replied:

The image you sent is a screenshot of a command line window containing an error message. The error message indicates that there is no version of the Visual Studio compiler found. This compiler is required to build the Omaha software.
Without the Visual Studio compiler, the Omaha build process will fail. You can try installing Visual Studio or finding a different way to build Omaha that does not require the Visual Studio compiler.

Thaks for the response @Saoiray , I had tried all the things related to Visual Studio 2022 but it didn’t worked out.