HELP] Can't install Gnome Shell extensions using Brave

Description of the issue:
In Chrome browser and Firefox I am able to install Gnome extensions after installing the gnome shell extensions browser addon.

This is the addon:

The documentation on this site tells me I need a connector app for chrome to work:
https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome/Installation

I installed it via the terminal with no problems but it does not seem to be working with Brave.

When I go to gnome-shell-extensions page it says
Although GNOME Shell integration extension is running, native host connector is not detected. Refer documentation for instructions about installing connector.

I imagine that Brave cannot use Chrome’s connector for some reason.

Exact URL of the website in question:
https://extensions.gnome.org/

Does the site work as expected when using Chrome?
I have no trouble with chrome

Brave version (check About Brave):
Version 1.28.105 Chromium: 92.0.4515.131 (Official Build) (64-bit)

Hello @boomerlife

which dist you using ? did you tried to check if disable the shield make difference or not ?

and have a nice day :slight_smile:

Distro is Ubuntu 21.04 gnome.
Shield disabled or not has no impact. Thank you.

this what i found about this issue
the issue is the connector with the chromium browser (any browser that based on chrome code)

check those

and this is the bug

on the last comment the guy say that it work if you install brave using the formal way https://brave.com/linux/#linux but if you install brave using snap it would not work

be careful with your current bats on your old installation

I have now uninstalled the snap version of Brave which I had gotten from the Ubuntu Store.
I then installed Brave using the instructions from the Brave website itself and the problems is solved.

I am now able to use Brave to manage extensions on Ubuntu 21.04.

Thank you all.

you very welcome and congratulations :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.