Hardware Accelerated Video Decode causes severe lag when watching multiple video streams at once


Description of the issue: Hardware Accelerated Video Decode causes severe lag when watching multiple video streams at once
How can this issue be reproduced?

  1. Launch the browser
  2. Open a YouTube video at 720p in a tab
  3. Open a Twitch stream at 720 in another tab or window (it helps to view them side by side)
  4. Wait a few seconds to see both video streams start buffering severely

Expected result: Both video streams should play at the expected resolution without any lag or buffering

Brave Version( check About Brave):
Version 1.23.73 Chromium: 90.0.4430.85 (Official Build) (64-bit)

Additional Information: Windows Task manager consistently shows a single thread out of my 16 thread CPU pinned at 99% usage while this issue occurs. The core usage is much more spread out when hardware acceleration is disabled, allowing for a smoother streaming experience.

I have an Intel i7-10700k CPU with an RTX 3070 GPU. My Internet speed it rated for 400mbps over ethernet confirmed via speedtest.net.

I tested 2 different 1080p streams, one youtube and one twitch on my 5950x/2080Super. I didn’t notice any unusual CPU load.

  • A VPN (which can affect video performance)
  • Using Wifi instead of Ethernet.
  • Other Applications using GPU/CPU resources.
  • Other browser tabs using GPU/CPU resources.

Could test with a 4K stream in Netflix or Youtube, in youtube you can turn on Stats for nerds

Tested by closing all browser windows, and testing from scratch to be fair.

Tested https://www.youtube.com/watch?v=WjoplqS1u18 (at 8k) Which did cause 50-70% increase in CPU performance hit. And some stuttering. though it would be expected.

I have no vpn software installed or running, and am connected with an ethernet cable.

I have retested with only a screen capture software and here are my results: https://youtu.be/58ZvHCvc3_U

At 2:42 in the video, you can see the massive performance improvement when disabling hardware acceleration.

Is there a better solution I can use than turning off hardware acceleration? The video very clearly shows the performance issue.

Updated to Brave Version 1.23.75 Chromium: 90.0.4430.93 (Official Build) (64-bit) and the performance issues still persist. Is there any better solution I can use than turning off hardware acceleration? Chrome and Firefox do not have the same issue.

I wasn’t able to reproduce any issues (as per gif posted), even with 1080p streams, maybe try from a new profile? (test with Brave Beta?)