Hangouts web app not updating when not focused

Google Hangouts (hangouts.google.com) web app is not updating unless the tab is currently in-focus. This is especially evident/troublesome when using a pop-out chat window.

Steps to reproduce:

  1. Open a new tab and navigate to hangouts.google.com (login if not already)
  2. Choose a conversation and click the pop-out icon.
  3. Move the popped out window where you can see it
  4. Click a different tab (not the hangouts tab)
  5. Keep your mobile device handy, but with display asleep
  6. Have a contact send you a message to your hangouts account

Actual Result
Note that your mobile device notification alert plays, but the popped-out window does not update.
The window will not update until you navigate the main browser back to the hangouts tab, and even then, sometimes not until you click into something or refresh

Expected result:
Pop-out window should update when messages are received. Previous version of Brave did this without trouble. Often, notifications appeared in-browser before mobile notifications.

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 1803 17134.1184 64-bit
Version 1.1.23 Chromium: 79.0.3945.88 (Official Build) (64-bit)

Not sure if this setting would help, but I cannot test it in any case.
When enable this setting, I get this relaunch button:
PushExample

However, when I click Relaunch, the switch reverts to off before the browser closes. When I reopen the browser, the setting remains disabled:
PushExample2

Known Issue: https://github.com/brave/brave-browser/issues/6633 Not sure if this is related to my problem, however.

1 Like

@G2theC,
Excellent reporting!
Can you check and see if you have Autoplay allowed on the site? If not, do so and see if this changes the behavior?

As for the second issue, as you stated it seems to be known and also closed and should be pushed into an upcoming update. Appreciate your patience.

Hi @Mattches,
Thanks for the reply!
Autoplay is globally disabled, to keep annoying ads/embeds from, well… auto-playing.

I will run some tests with this setting to see if this solves my problem. I noticed today that there may be other factors involved, as the popped-out window has been updating for the past few hours without my normal work-around required.

Thanks again for the help! I’ll post back with my results.
-G

2 Likes

Problem seems to have self-resolved
Did not attempt work-around

Well, the problem is back. I was away from my desk and got several mobile notifications from my pocket. I walked back to my desk, and saw that the opo-out window still showed the last message I received, over two hours ago.

Can you check and see if you have Autoplay allowed on the site? If not, do so and see if this changes the behavior?

This setting had no effect. I am still missing messages.

@G2theC,
Testing a few things now – sorry for the wait. Will return in just a moment with more info.

@G2theC,
To confirm – you do see the message in the hangouts window, right? It’s just the notification that doesn’t go off? I just tested this on macOS and Windows 10 and it seems to be functioning as intended, notifications and all.

Can you try creating a new browsing profile and see if you get the same results? I’m wondering if it’s a caching issue.

The problem is elusive. I closed and re-opened the browser and it started working again.

To your question:

To confirm – you do see the message in the hangouts window, right? It’s just the notification that doesn’t go off?

No, I don’t see the message, and the usual green “new message” color doesn’t occur until I go to the hangouts tab again. The notification I do hear is from my phone, in my pocket.

Steps to reproduce:

  1. Open a new tab and navigate to hangouts (login if not already)
  2. Choose a conversation and click the pop-out icon.
  3. Move the popped out window where you can see it
  4. Click a different tab (not the hangouts tab)
  5. Keep your mobile device handy, but with display asleep
  6. Have a contact send you a message to your hangouts account
1 Like

@G2theC,
Appreciate the exact steps. I did follow but can’t seem to reproduce the issue. Did you try with a fresh browsing profile yet?

The problem seems related to leaving the browser open and hibernating (at the end of the work day), then resuming the session the next day. If I close the browser and re-open, the problem goes away.
Not sure if this is something devs would want to know about, or if this would be considered a far out side outlier.

Otherwise, I think we can close this one.