Groww.in website is not working properly

There is a website groww.in is not working properly since last week. In the website when I am clicking on links then that page does not open. I tried disabling the shield but it does not affect anything. I tried this in other browsers and it is working there. Please check @Mattches @Saoiray


**Brave Version( check About Brave):
Version 1.44.108 Chromium: 106.0.5249.103 (Official Build) (64-bit)

Additional Information:

@MichaelStan,
Thank you for reaching out.
I’ve created an account quickly (didn’t KYC so I don’t have access to all pages) but everything seems to be working for me on my end. Tested on both macOS and Windows systems.

Can you be more specific about which links aren’t working as well as which OS you’re using at this time?

1 Like

Just a FYI. I tried it and everything works fine for me including links. I’m on Windows 11.

2 Likes

thanks for reaching out to me. Now it is working well. If any problem occurs in future, I will let you know.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.