Google Workspace no longer works on Brave Desktop

I’ve been using Brave to login and use Google Workspace / G-Suite for nearly 2 years. No problems at all. Then yesterday out of the blue I started to get 400 errors like this when trying to open Gmail, Google Calendar, Drive etc:

image

I uninstalled and reinstalled Brave but the problem persists. This problem does not exist on any other sites I log in to i.e. Office 365, protonmail etc. Likewise I have no problems logging into Google Workspace from other web browsers. Interestingly, I can also log in to Google Workspace on my smart phone using Brave.

So, not sure what’s going on but wanted to see if anyone else has encountered this problem.

Thanks

1 Like

Hi

The 400_ERROR was solved in other posts by disabling Brave Shield, the orange icon on the top. I hope this works for you.

I had the same problem and disabling the shield worked for me, but that doesn’t seem like an ideal solution. The whole purpose of Brave is to block the user data tracking. Turning off the shield disables those tracking blockers. This feels like a corporate strategy from Google to stick it to Brave, but I’d like to hear from others with more knowledge of the situation than me.

Hi

I have been using Brave for several months and I have (almost) never have a problem with it.
You are right as regards Brave shield. I have proposed this solution because many users solved the 400 issue, and issues related to google email by disabling the shield. BUT, the amazing thing is that Brave Shield is always on on my device. For instance when opening Google workspace, a very brieve black screen appeared for a fraction of a second which showed like an error, then the page opened normally.
Yesterday I posted my Brave browser settings to a user, I hope this may be of some help to you.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.