Google websites are not responsive


Description of the issue: when making use of certain Google websites, the sites get stuck at loading or, when fully loaded, the website components are not responsive.
How can this issue be reproduced?

  1. Make a Google search
  2. Wait for a couple seconds (or scroll through the page).
  3. Try to click one of the results.
  4. Try the same with Calendar

Expected result: Components are responsive and page loads

Brave Version( check About Brave): Version 1.32.106 Chromium: 96.0.4664.45 (Official Build) (arm64)

Additional Information: I am on macOs 12.0.1 and have an Apple M1 Pro chip.

I am having the exact same issue as the above person (iNano). Google-specific sites are all freezing on the loading screens and timing out due to a “Out of Memory” error. My issue started about 1-2 days ago.

Description of the issue: when making use of certain Google websites, the sites get stuck at loading or, when fully loaded, the website components are not responsive.
How can this issue be reproduced?

  1. Try opening Google Gmail, Drive, Sheets, Docs sites.
  2. Have page partially load, hang, and eventually freeze with either a popup asking if you want to wait or kill the page.
  3. If you choose to wait, eventually you receive the “out of memory” error. Viewing memory on Windows task manager, you see the website continuously increases in memory until it goes over 2 GB and dies.

Expected result: Components are responsive and page loads

Brave Version( check About Brave ): Version 1.32.106 Chromium: 96.0.4664.45 (Official Build)

Additional Information: Windows 10 Home (v. 10.0.19043) on an ASUS G14 with Ryzen 4900HS, 16 gb RAM

Happening to me as well. About a week now. Pretty much anything google will freeze then crash

And here is a link to the recurring crash report on OneDrive. Hopefully the powers that be will take notice.

Thank you for reporting – can you both please try visiting the relevant Google sites in a private browsing window and tell me whether or not you get the same results?

1 Like

Can confirm I don’t have these issues in a private tab.

Should emptying my cache solve the issue?

Just tried it and yes indeed…Still freezes and crashes

@Georgetheavguy,

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Can confirm clearing Google website cache does not solve the issue.

Well how “Awesome “ are you! Thank you for reaching out and yes, that was the issue. I’m not sure why it starting happening out of the blue, but grateful that it’s fixed. Well done M…You rock!

George

1 Like

@Mattches

I just turned off hardware acceleration, but I am still experiencing the same issues. Also, private tabs do not have the same issues for me.

Is there anything else I can try?

@iNano,
Can you try creating a new, temp. profile and test to see if you get the same results there? Please ensure that you’ve closed all other Brave windows except for the one with the newly created profile when performing the test.

Thank you.

Thanks for the steps.

By turning off all extensions and enabling them one by one, I managed to single out the XDEFI wallet extension to be the culprit.

Looking at the task manager, the only thing that stands out to me is the very big amount of script cache it is consuming.

I’ll report this issue with them and consider this issue closed. Thanks again @Mattches .

1 Like

For anyone that stumbles across this.

I contacted XDEFI support. They told me to enable/disable or disable/enable the Prioritise XDEFI option in the Settings.

After doing this, the issue was gone.

1 Like

@iNano,
Thank you for reporting this information – I will be sure to pass this onto the team for further review.