Google Signon fails on turo.com

Description of the issue:
Selecting Google for sign-on results in "Failed to load script: {“global”:“gapi”,“url”:"https://apis.google.com/js/api.js"}"
Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to turo.com
  2. Select Log In
  3. Press Continue with Google button
    Actual Result (gifs and screenshots are welcome!):

    Expected result:
    Google should pop up the account selection dialog.
    Reproduces how often:
    Every time.
    Operating System and Brave Version(See the About Brave page in the main menu):
    OS Name Microsoft Windows 10 Enterprise N Version 10.0.19044 Build 19044
    Brave Version 1.39.111 Chromium: 102.0.5005.61 (Official Build) (64-bit)

    Additional Information:
    Works on Chrome, Opera, Firefox, and Edge.

Can you please test this with Shields down to see if the issue persists?

I’m not aware of how Shields works. I turned it off on my main tab (Gmail) with this email open. Then I opened a new tab and noticed the lion was black. I entered turo.com and the lion turned red, and Google signon worked fine. So I turned off Shields, and it still worked on that tab. Now it works every time regardless whether I turn Shields off or on. I don’t understand why this off/on sequence seems to have fixed it.

Anyone can run this test you requested; you don’t need a turo ID to do it.

Well that’s pretty strange. Yeah for me this works with default Shields settings and without having to make any adjustments. I was able to login to the site using Google without any issues.

I will leave this thread open in case the issue occurs for you again.

Shields up, I tested and it worked OK again.

Thanks for helping.

You’re very welcome — please let me know if the issue occurs again