Google sign in buttons not working

Description of the issue: Google sign in buttons not working

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no) Yes

Does the site function as expected when Shields are turned off? Yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): No

Does the site work as expected when using Chrome? No

Brave version (check About Brave): 1.49.120

A lot of weird things are happening with Google. First of all, Google sign in buttons not responding. When I’m using the “continue with google” options on websites, when I click on my google profile nothing happens. The element shows is highlighted when I put my mouse over it, but when I click my mouse, nothing happens - it’s just not responsive. I also tried hitting “enter” on my keyboard, still no luck. I tried turning off my shields and allowing all cookies, cleared my cache, pretty much a combination of all things; still nothing working. I’m still logged into my main account through Gmail, so then, I tried signing out of all my accounts and then logging back into my accounts, but when I tried to sign into my main account, I have 2fa and when i click the prompt on my phone, nothing registers on my computer. i do it again and still nothing happens. I’ve tried switching to another wifi network, resetting my computer, turned off my vpn, cleared my browsing history and cache, tried logging in on an icognito tab, tried using different browsers, set a custom dns server ( and a hard network reset on windows network & internet. I uninstalled brave, reinstalled it and it still doesn’t work. I tried it with pretty much every other browser as well. The only thing that I have gotten close to working is to disable the “script” setting in brave shields, which allows me to sign into gmail. However that strategy doesn’t work for the “continue with google” option that most websites have nowadays. The only other way I have somewhat solved is by downloading Tor browser and logging in through that way. However, I use brave more often than any other browser so I thought to ask this question here.

Could you try in a private window or a new profile ?

@BananaBatrick Sounds like you’re saying it’s in your Shields settings. This is especially true if you’ve enabled the Block Scripts option for Shields, as that SHOULD NOT be a default setting. It would break a lot of sites and content.

You’re sharing that when you disable Shields, that everything works. So now the question is, what are your Shields settings like? If you have things set to the most aggressive as can be, then it might explain your issues.

Can you confirm which Shields settings you’re using? Perhaps trying to enable it to be as I share at PSA: Current FAQ - #28 by Saoiray ?

My current brave shield settings are uploaded. They should be the default settings since I did a fresh reinstall of Brave. As for logging in in a private and guest window, I am still unsuccessful. For the 2fa, it still doesn’t process that I’ve actually selected “yes” on my phone and is stuck on the same prompt screen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.