Google search autoplay previews


#1

When google searching for something that returns video results, a preview autoplays. This triggers brave to give the notification that media is playing. The notifications can be paused and swiped away, but also persist after switching tabs or apps.

I’ve turned off autoplay in brave settings, google search settings, and the google app.


#2


#3

Could you share the device details. I can’t see this issue on Andoid 5.0 on tablet


#4

Samsung Note 3 VZW on Android 7.1.2


#5

Is it possible to record the steps? I am not able to reproduce the issue on my device

cc: @LaurenWags @Alexey


#6

In the attached screenshot I searched for ‘brave walkthrough’ and it gives mostly web results, but also a section for video results. The first result preview autoplays and gives the media playback icon (there is no audio)

When searching for something like ‘brave videos’ however, it returns primarily video results and does not autoplay


#7

Hi @msx_asdf

I am able to reproduce this on a device of mine. Just so I’m clear, is your issue that the preview autoplays or that you have the media playback icon (or both issues)? I want to make sure I identify this correctly when writing up the issue.

Here are my steps to reproduce:
Open Brave, go to Settings > Site Settings > Media. Turn off Autoplay.
Open a new tab (Google is the search engine).
Search for 'brave walkthrough’
Tab displays search results.
Wait a couple of seconds, the first video in the list will do an auto preview.
Up in the notifications bar, see the media icon (speaker).
Search again for 'brave videos’
Tab displays search results.
No videos on page show an auto preview.
No media icon is displayed in the notifications bar.

Also, for reference, something similar happens when using Chrome:
Open Chrome, go to Settings > Site Settings > Media. Turn off Autoplay.
Open a new tab (Google is the search engine).
Search for 'brave walkthrough’
Tab displays search results.
Wait a couple of seconds, the first video in the list will do an auto preview.
However, up in the notifications bar, no media icon is displayed.

Thanks,
Lauren


#8

The main concern is the playback notification. As noted, the notification sticks even after navigating away from the tab.

But with all autoplay settings disabled, neither should be occurring.


#9

Hi @msx_asdf

I’m not able to reproduce this on the latest version, could you let me know if it’s still occurring for you?

Thanks,
Lauren


#10

@LaurenWags

Takes a second or so longer to initiate, but yes, it is still occuring

I cleared all browsing data, reinstalled brave, turned the autoplay settings back off in google search and brave options

(‘brave walkthrough’ gave me just video results, so used search terms ‘destiny walkthrough’ and ‘pc build’)


#11

Thanks @msx_asdf - I was able to reproduce it this time, not sure why I couldn’t reproduce it before.

Logged issue below. Thank you for taking the time to report this!

https://github.com/brave/browser-android-tabs/issues/479

Lauren


#12

I have this issue too. Pixel 2, 8.1, latest Brave


#13

Same problem, Samsung Note 2, Android 4.4.2. I’m using google.CA

Sometimes I don’t see the “Videos” div, but that might be a Google-end thing. Disabling scripts on google.ca is my workaround.


#14

I too have the same issue. Moto Z Force, Nougat, latest Brave. Please fix. Thank you!


#15

I am having the same issue and it drives me nuts as it pauses any media I am listening to for the video preview to play. I turned off notifications for Brave so I no longer get the media in notification bar but I as soon as the video preview begins, it pauses any media I currently have playing. Please help.

Nexus 6P, 8.1.0, latest version of Brave